Bug 1284665 - Why in each zip archive I see home folder?
Why in each zip archive I see home folder?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: file-roller (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
: 1298547 (view as bug list)
Depends On: 1327734
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 15:22 EST by Mikhail
Modified: 2016-05-02 14:54 EDT (History)
9 users (show)

See Also:
Fixed In Version: file-roller-3.16.5-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-02 14:54:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (159.19 KB, image/png)
2015-11-23 15:22 EST, Mikhail
no flags Details

  None (edit)
Description Mikhail 2015-11-23 15:22:57 EST
Created attachment 1097839 [details]
screenshot

Description of problem:
Why in each zip archive I see home folder?

$ file-roller --version
file-roller 3.16.4, Copyright © 2001-2012 Free Software Foundation, Inc.
Comment 1 Daniele Viganò 2015-11-27 07:26:50 EST
Same problem here (only with zip files)

file-roller-3.16.4-1.fc23
Comment 2 Christian Stadelmann 2015-12-01 08:20:48 EST
This is not only true for your home directory. File-roller displays the path a file resides in in any .zip file.
Comment 3 Ilja Sekler 2015-12-06 11:17:06 EST
Please see https://bugzilla.gnome.org/show_bug.cgi?id=757793

file-roller misinterprets the version string of p7zip 15.09 as pre-4.55. file-roller uses 7za instead of unzip for zip files if available.
Comment 4 Marek Novotny 2016-01-14 06:57:06 EST
I am experiencing this issue too. 

I looked at https://bugzilla.gnome.org/show_bug.cgi?id=757793, but after un-installing p7zip package, file-roller still shows home directory nested in archive.

rpm -q file-roller
file-roller-3.16.4-1.fc23.x86_64

 rpm -q p7zip
package p7zip is not installed

rpm -q unzip
unzip-6.0-24.fc23.x86_64
Comment 5 Manuel Bejarano 2016-02-21 14:42:58 EST
Hi,

This problem is still present in Fedora 23. In the mentioned bug report, there is a patch that supposedly fixes the issue:

https://bugzilla.gnome.org/attachment.cgi?id=316844&action=diff

Please, can you confirm if this patch has been applied to file-roller in Fedora? If not, is it possible for any of you to apply the patch so we can test?

Thank you!
Comment 6 Ilja Sekler 2016-02-21 16:24:39 EST
(In reply to Manuel Bejarano from comment #5)

> Please, can you confirm if this patch has been applied to file-roller in
> Fedora?

No, unfortunately, it has not:

http://pkgs.fedoraproject.org/cgit/rpms/file-roller.git/log/?h=f23

There is a bunch of other fixes on the 3.16 branch awaiting their chance to get to GNOME users too:

https://git.gnome.org/browse/file-roller/log/?h=gnome-3-16

I've just realized that I was using a local file-roller build containing the patch once the latter became available.

> If not, is it possible for any of you to apply the patch so we can
> test?

Setting up rpmbuild, installing the src.rpm of file-roller, dropping the patch into the SOURCES directory, referencing it in the .spec file*, installing build dependencies

# dnf builddep file-roller

and running

rpmbuild -bb file-roller.spec

within the SPECS directory is not difficult, you need only a tiny subset of the information provided in

https://fedoraproject.org/wiki/How_to_create_an_RPM_package

to accomplish this, but I do hope that Fedora maintainers either cherry-pick this particular patch, or the GNOME releases a 3.16.5 version of file-roller containing all recent fixes on the branch soon.

*) Add

Patch0:         file-roller-3.16.4-bug-757793.patch

after the line with the "Source:" tag and

%patch0 -p1 -b .p7zip

in the %prep section after the line with "%setup". Incrementing "Release" will prevent dnf overwriting the patched package with the stock one.
Comment 7 Marek Novotny 2016-02-22 08:45:27 EST
I built patched file-roller localy and it works fine.

I uploaded the srpm into ad-hoc copr repository https://copr.fedorainfracloud.org/coprs/mnovotny/File-roller-fixbug-757793/ so i can use it later or anybody can install it.
Comment 8 Daniele Viganò 2016-02-22 10:16:35 EST
Thanks Marek, your packages are working fine for me. No more additional folders in the archive.
Comment 9 Manuel Bejarano 2016-02-22 18:07:11 EST
Hi,

Thank you Ilja & Marek for your quick answer and help. Ilja, I have saved your instructions in case I need them in the future, thanks for the tip!

I installed the packages compiled by Marek and they bug is gone. One thing though, adding the repository the usual way: "dnf copr enable mnovotny/File-roller-fixbug-757793" works but dnf fails to sync the contents (I ignore if that is the normal behavior):

"Failed to synchronize cache for repo 'mnovotny-File-roller-fixbug-757793' from 'https://copr-be.cloud.fedoraproject.org/results/mnovotny/File-roller-fixbug-757793/fedora-23-x86_64/': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling."

It looks like repomd.xml is in "mnovotny/File-roller-fixbug-757793/fedora-23-x86_64/devel/repodata/".

Cheers!
Comment 10 Marek Novotny 2016-02-23 04:24:19 EST
I saw that error while syncing too, not sure what was wrong. I used copr for first time ;) so I perhaps forgot regenerating the repository yesterday. Anyway I did regenerating again manually and the dnf error is gone.
Comment 11 biltong 2016-03-07 05:24:26 EST
*** Bug 1298547 has been marked as a duplicate of this bug. ***
Comment 12 biltong 2016-03-07 05:25:32 EST
The non-patched behaviour is kind of dangerous, could the patch be merged for the fedora release?
Comment 13 Jeremy Newton 2016-03-31 23:17:45 EDT
Is there a reason this patch hasn't been accepted if it fixes the issue?
Comment 14 Jeremy Newton 2016-03-31 23:22:02 EDT
Note that this has been accepted upstream in the 3.20 release, but really should be backported to f22 and f23:

https://github.com/GNOME/file-roller/commit/ed9c3fd29071591d3b217c5807de3d71ff7540d0
Comment 15 Matthias Clasen 2016-04-11 09:04:22 EDT
I've asked Paolo to do a final 3.16 tarball with the accumulated bug fixes on the branch.
Comment 16 Fedora Update System 2016-04-11 22:00:13 EDT
file-roller-3.16.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-feb00cca4b
Comment 17 Fedora Update System 2016-04-13 05:27:01 EDT
file-roller-3.16.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-feb00cca4b
Comment 18 Fedora Update System 2016-04-25 15:20:01 EDT
file-roller-3.16.5-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-feb00cca4b
Comment 19 Fedora Update System 2016-04-26 21:21:33 EDT
file-roller-3.16.5-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-feb00cca4b
Comment 20 Fedora Update System 2016-05-02 14:54:00 EDT
file-roller-3.16.5-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.