Bug 1284752 - quota cli: enhance quota list command to list usage even if the limit is not set
quota cli: enhance quota list command to list usage even if the limit is not set
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
x86_64 Unspecified
medium Severity medium
: ---
: ---
Assigned To: Manikandan
: FutureFeature, Triaged
Depends On:
Blocks: 1289063
  Show dependency treegraph
 
Reported: 2015-11-24 01:40 EST by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1289063 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:46:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-11-24 01:40:54 EST
As of now quota 'list/list-objects' will list the usage only if limit is set.

# gluster volume quota vol1 list-objects /abc
                  Path                   Hard-limit   Soft-limit      Files       Dirs     Available  Soft-limit exceeded? Hard-limit exceeded?
-----------------------------------------------------------------------------------------------------------------------------------------------
/abc                                     Limit not set


Enhance this list command to display usage even if the limit is not set
Comment 1 Vijay Bellur 2015-11-25 02:35:26 EST
REVIEW: http://review.gluster.org/12741 (cli/quota: show used_space,(file,dir) count even when quota limit is not set) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2015-11-25 04:36:11 EST
REVIEW: http://review.gluster.org/12741 (cli/quota: show used_space,(file,dir) count even when quota limit is not set) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 3 Vijay Bellur 2015-12-04 03:43:31 EST
REVIEW: http://review.gluster.org/12741 (cli/quota: show used_space,(file,dir) count even when quota limit is not set) posted (#4) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 4 Vijay Bellur 2015-12-08 07:54:55 EST
COMMIT: http://review.gluster.org/12741 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 72334e2209b8b506f00d5d851bfb5fdc3eb38cf4
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Wed Nov 25 00:04:39 2015 +0530

    cli/quota: show used_space,(file,dir) count even when quota limit is not set
    
    Problem:
    As of now quota 'list/list-objects' will list the usage only if limit is
    set for every directory else it will fail with ENOATTR(If inode/inode-quota
    is already configured for the first time).
    
    Feature:
    With the patch we are enhancing this command to list the usage even
    if quota limit is not set but still the user has to configure
    inode/inode-quota for the first time.
    
    Example:
    Consider we have /client/dir and /client1(absolute path from mount point):
    Quota limit is set only on /client. when we try listing /client/dir or /client1,
    it shows "Limit not set".
    
    Fix:
    The patch fixes this by showing "used space" in case of list command and
    shows "file_count" & "dir_count" in case of list-objects command. This works
    fine with xml output as well.
    
    Change-Id: I68b08ec77a583b3c7f39fe4d6b15d3d77adb095a
    BUG: 1284752
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12741
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 5 Vijay Bellur 2015-12-14 06:51:45 EST
REVIEW: http://review.gluster.org/12961 (tests/bugs/quota : list quota usage even if limit is not set) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 6 Mike McCune 2016-03-28 19:10:48 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 8 Niels de Vos 2016-06-16 09:46:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.