Bug 1289063 - quota cli: enhance quota list command to list usage even if the limit is not set
quota cli: enhance quota list command to list usage even if the limit is not set
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.6
x86_64 Unspecified
medium Severity medium
: ---
: ---
Assigned To: Manikandan
: FutureFeature, Triaged
Depends On: 1284752
Blocks: glusterfs-3.7.7
  Show dependency treegraph
 
Reported: 2015-12-07 06:12 EST by Manikandan
Modified: 2016-09-20 00:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1284752
Environment:
Last Closed: 2016-02-16 03:56:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-12-07 06:12:27 EST
+++ This bug was initially created as a clone of Bug #1284752 +++

As of now quota 'list/list-objects' will list the usage only if limit is set.

# gluster volume quota vol1 list-objects /abc
                  Path                   Hard-limit   Soft-limit      Files       Dirs     Available  Soft-limit exceeded? Hard-limit exceeded?
-----------------------------------------------------------------------------------------------------------------------------------------------
/abc                                     Limit not set


Enhance this list command to display usage even if the limit is not set

--- Additional comment from Vijay Bellur on 2015-11-25 02:35:26 EST ---

REVIEW: http://review.gluster.org/12741 (cli/quota: show used_space,(file,dir) count even when quota limit is not set) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-25 04:36:11 EST ---

REVIEW: http://review.gluster.org/12741 (cli/quota: show used_space,(file,dir) count even when quota limit is not set) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-04 03:43:31 EST ---

REVIEW: http://review.gluster.org/12741 (cli/quota: show used_space,(file,dir) count even when quota limit is not set) posted (#4) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 1 Vijay Bellur 2015-12-07 06:23:04 EST
REVIEW: http://review.gluster.org/12893 (quota: show used_space,(file,dir) count even when quota limit is not set) posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2015-12-10 09:15:07 EST
COMMIT: http://review.gluster.org/12893 committed in release-3.7 by Kaushal M (kaushal@redhat.com) 
------
commit e0b2bcf34b57f75a244ef88341b0f3d5990c768b
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Wed Nov 25 00:04:39 2015 +0530

    quota: show used_space,(file,dir) count even when quota limit is not set
    
    Problem:
    As of now quota 'list/list-objects' will list the usage only if limit is
    set for every directory else it will fail with ENOATTR(If inode/inode-quota
    is already configured for the first time).
    
    Feature:
    With the patch we are enhancing this command to list the usage even
    if quota limit is not set but still the user has to configure
    inode/inode-quota for the first time.
    
    Example:
    Consider we have /client/dir and /client1(absolute path from mount point):
    Quota limit is set only on /client. when we try listing /client/dir or /client1,
    it shows "Limit not set".
    
    Fix:
    The patch fixes this by showing "used space" in case of list command and
    shows "file_count" & "dir_count" in case of list-objects command. This works
    fine with xml output as well.
    
    Backport of http://review.gluster.org/#/c/12741/
    
    Cherry-picked from commit 608c646cc00e2c1c0b9c87e9fd7cb9e1eb271db2
    > Change-Id: I68b08ec77a583b3c7f39fe4d6b15d3d77adb095a
    > BUG: 1284752
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    
    Change-Id: I68b08ec77a583b3c7f39fe4d6b15d3d77adb095a
    BUG: 1289063
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12893
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 3 Kaushal 2016-04-19 03:50:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.