Bug 1284789 - Snapshot creation after attach-tier causes glusterd crash
Snapshot creation after attach-tier causes glusterd crash
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
:
Depends On:
Blocks: 1285166 1285629
  Show dependency treegraph
 
Reported: 2015-11-24 04:00 EST by Avra Sengupta
Modified: 2016-06-16 09:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1285166 1285629 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:46:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avra Sengupta 2015-11-24 04:00:31 EST
Description of problem:
Snapshot creation fails after attach-tier and glusterd crashes

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a replica 2 volume
2. Attach a replica 2 tier
3. Take a snapshot

Actual results:
glusterd crashes


Expected results:
glusterd should not crash


Additional info:
Comment 1 Vijay Bellur 2015-11-24 06:58:23 EST
REVIEW: http://review.gluster.org/12734 (glusterd: copy snapshot object during duplication of volfile) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-11-25 01:42:18 EST
REVIEW: http://review.gluster.org/12734 (glusterd: copy snapshot object during duplication of volfile) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Vijay Bellur 2015-11-26 01:16:33 EST
COMMIT: http://review.gluster.org/12734 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit c85c805e980f7981dc7c87d87ef2283931c0be18
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Nov 24 13:45:20 2015 +0530

    glusterd: copy snapshot object during duplication of volfile
    
    When creating duplicate volfile for hot/cold tier, we need to
    copy the snapshot object in to volfile as it requires to generate
    snapshot brick volfile.
    
    Change-Id: I39ccfa20cd1c16ef2801901e3cd3a31c76f8995d
    BUG: 1284789
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12734
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:46:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.