Bug 1285629 - Snapshot creation after attach-tier causes glusterd crash
Snapshot creation after attach-tier causes glusterd crash
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
:
Depends On: 1284789
Blocks: 1285166
  Show dependency treegraph
 
Reported: 2015-11-26 00:50 EST by Mohammed Rafi KC
Modified: 2016-04-19 03:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1284789
Environment:
Last Closed: 2016-02-15 03:53:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2015-11-26 00:50:30 EST
+++ This bug was initially created as a clone of Bug #1284789 +++

Description of problem:
Snapshot creation fails after attach-tier and glusterd crashes

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a replica 2 volume
2. Attach a replica 2 tier
3. Take a snapshot

Actual results:
glusterd crashes


Expected results:
glusterd should not crash


Additional info:

--- Additional comment from Vijay Bellur on 2015-11-24 06:58:23 EST ---

REVIEW: http://review.gluster.org/12734 (glusterd: copy snapshot object during duplication of volfile) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-25 01:42:18 EST ---

REVIEW: http://review.gluster.org/12734 (glusterd: copy snapshot object during duplication of volfile) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 1 Vijay Bellur 2015-11-26 00:50:57 EST
REVIEW: http://review.gluster.org/12756 (glusterd: copy snapshot object during duplication of volfile) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-11-26 06:41:51 EST
COMMIT: http://review.gluster.org/12756 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 5a52abb4af0d2d36e1b24e80cbfd349a9442a329
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Nov 24 13:45:20 2015 +0530

    glusterd: copy snapshot object during duplication of volfile
    
    Back port of > http://review.gluster.org/#/c/12734/
    
    When creating duplicate volfile for hot/cold tier, we need to
    copy the snapshot object in to volfile as it requires to generate
    snapshot brick volfile.
    
    >Change-Id: I39ccfa20cd1c16ef2801901e3cd3a31c76f8995d
    >BUG: 1284789
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    
    Change-Id: Ia0892dfc3af24ee428e0aa0a3e23063a91049a57
    BUG: 1285629
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12756
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 3 Kaushal 2016-04-19 03:49:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.