Bug 1284870 - (RHEL7) Poor performance of sequential/streaming I/O over SMB
(RHEL7) Poor performance of sequential/streaming I/O over SMB
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
Unspecified Unspecified
high Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: rhs-smb@redhat.com
Ben Turner
: ZStream
Depends On:
Blocks: 1260783 1292624
  Show dependency treegraph
 
Reported: 2015-11-24 06:22 EST by Michael Adam
Modified: 2016-03-01 01:09 EST (History)
11 users (show)

See Also:
Fixed In Version: samba-4.2.4-10.el7rhgs
Doc Type: Enhancement
Doc Text:
With this release, asynchronous I/O from Samba to Red Hat Gluster Storage is supported. The 'aio read size' option is now set to 4096, which enables asynchronous I/0 for reads by default. This increases the throughput when the client is multithreaded or there are multiple programs accessing the same share.
Story Points: ---
Clone Of:
: 1292624 (view as bug list)
Environment:
Last Closed: 2016-03-01 01:09:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0326 normal SHIPPED_LIVE gluster-smb bug fix and enhancement update 2016-03-01 05:30:56 EST

  None (edit)
Description Michael Adam 2015-11-24 06:22:10 EST
Description of problem:

Streaming read / write workloads perform poorly with Samba/SMB on top of Gluster, when compared to NFS or native client. On the other hand, on local file systems, SMB is fast.


More details to follow.
Comment 6 Ben Turner 2016-02-09 16:15:25 EST
71% perf improvement on writes and 100% improvement on reads, verified.
Comment 7 Ben Turner 2016-02-09 16:17:53 EST
Note that with Linux clients we SHOULD NOT be using AIO, there are issues with the cifs kernel module that need to be addressed before we recommend AIO with linux cifs.  AIO is recommended for Windows and is enabled by default.
Comment 10 Michael Adam 2016-02-24 06:09:10 EST
looks good to me. Thanks!
Comment 12 errata-xmlrpc 2016-03-01 01:09:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0326.html

Note You need to log in before you can comment on or make changes to this bug.