Bug 1292624 - (RHEL6) Poor performance of sequential/streaming I/O over SMB
(RHEL6) Poor performance of sequential/streaming I/O over SMB
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
Unspecified Unspecified
high Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: rhs-smb@redhat.com
Ben Turner
: ZStream
Depends On: 1284870
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-12-17 18:21 EST by Michael Adam
Modified: 2016-03-01 01:13 EST (History)
12 users (show)

See Also:
Fixed In Version: samba-4.2.4-10.el6rhs
Doc Type: Bug Fix
Doc Text:
With this release, asynchronous I/O from Samba to Red Hat Gluster Storage is supported. The 'aio read size' option is now set to 4096, which enables asynchronous I/0 for reads by default. This increases the throughput when the client is multithreaded or there are multiple programs accessing the same share.
Story Points: ---
Clone Of: 1284870
Environment:
Last Closed: 2016-03-01 01:13:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 6 Anjana Suparna Sriram 2016-02-05 05:14:08 EST
Please review the doc text and sign off to be included in 3.1.2 errata.
Comment 7 Michael Adam 2016-02-05 06:15:37 EST
The text looks good to me.
I'd like Ira to verify it as well.
Comment 8 Ira Cooper 2016-02-05 09:09:38 EST
My suggestion:

With this release, asynchronous IO from Samba to Gluster is supported and the AIO read option is enabled by default in smb.conf. This increases the throughput when the client is multithreaded or there are multiple programs accessing the same share.

----

It doesn't really impact us in the multiple client case.
Comment 9 Ben Turner 2016-02-09 16:16:00 EST
71% perf improvement on writes and 100% improvement on reads, verified.
Comment 10 Ben Turner 2016-02-09 16:17:48 EST
Note that with Linux clients we SHOULD NOT be using AIO, there are issues with the cifs kernel module that need to be addressed before we recommend AIO with linux cifs.  AIO is recommended for Windows and is enabled by default.
Comment 13 Ira Cooper 2016-02-19 01:45:19 EST
1. By default in Samba it is set to 0.

We've changed our smb.conf in RHGS to set it to 4096.

2. Same value, we don't know what the client type is.

If you have Linux clients using SMB2+ you need to disable AIO, at current.

-Ira
Comment 18 Michael Adam 2016-02-24 06:13:15 EST
Looks good. Thanks.
Comment 20 errata-xmlrpc 2016-03-01 01:13:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0324.html

Note You need to log in before you can comment on or make changes to this bug.