Bug 1284906 - cp will corrupt sparse files with trailing extents
Summary: cp will corrupt sparse files with trailing extents
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: coreutils   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Kamil Dudka
QA Contact: Jakub Prokes
Petr Bokoc
URL:
Whiteboard:
Keywords: Patch, Reproducer, ZStream
Depends On:
Blocks: 1285365
TreeView+ depends on / blocked
 
Reported: 2015-11-24 12:48 UTC by Pádraig Brady
Modified: 2016-11-04 07:40 UTC (History)
5 users (show)

Fixed In Version: coreutils-8.22-16.el7
Doc Type: Bug Fix
Doc Text:
Copying sparse files with trailing extents using "cp" no longer causes data corruption When creating sparse files, the *fallocate* utility could allocate extents beyond EOF using `FALLOC_FL_KEEP_SIZE`. As a consequence, when there was a gap (hole) between the extents, and EOF was within that gap, the final hole was not reproduced, which caused silent data corruption in the copied file due to its size being too small. With this update, the "cp" command ensures that extents beyond the apparent file size are not processed, as such processing and allocating is not currently supported. As a result, silent data corruption in certain type of sparse files no longer occurs.
Story Points: ---
Clone Of:
: 1285365 (view as bug list)
Environment:
Last Closed: 2016-11-04 07:40:06 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2497 normal SHIPPED_LIVE coreutils bug fix update 2016-11-03 14:11:50 UTC

Description Pádraig Brady 2015-11-24 12:48:38 UTC
cp will corrupt copies of a file that has:

1. a hole up to the apparent size of the file.
2. an extent after the apparent EOF.

To reproduce:

echo blabla > sparse_falloc.in
truncate -s 2M sparse_falloc.in
fallocate -n -o 4M -l 1M sparse_falloc.in
cp sparse_falloc.in sparse_falloc.out
cmp sparse_falloc.in sparse_falloc.out || echo corrupt

Upstream backportable fix is at:
http://git.sv.gnu.org/gitweb/?p=coreutils.git;a=patch;h=eea6b49

Comment 1 Ondrej Vasik 2015-11-25 10:34:33 UTC
Thanks Pádraig for heads-up.

Comment 10 errata-xmlrpc 2016-11-04 07:40:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2497.html


Note You need to log in before you can comment on or make changes to this bug.