Bug 1285365 - cp will corrupt sparse files with trailing extents
cp will corrupt sparse files with trailing extents
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: coreutils (Show other bugs)
7.2
All Unspecified
urgent Severity high
: rc
: ---
Assigned To: Ondrej Vasik
qe-baseos-daemons
: Patch, Reproducer, ZStream
Depends On: 1284906
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 08:26 EST by Jan Kurik
Modified: 2016-02-16 05:24 EST (History)
6 users (show)

See Also:
Fixed In Version: coreutils-8.22-15.el7_2.1
Doc Type: Bug Fix
Doc Text:
When creating sparse files, the fallocate utility could allocate extents beyond EOF using FALLOC_FL_KEEP_SIZE. As a consequence, when there was a gap (hole) between the extents, and EOF was within that gap, the final hole was not reproduced, which caused silent data corruption in the copied file due to its size being too small. With this update, the cp command ensures that extents beyond the apparent file size are not processed, as such processing and allocating is not currently supported. As a result, silent data corruption in certain type of sparse files no longer occurs.
Story Points: ---
Clone Of: 1284906
Environment:
Last Closed: 2016-02-16 05:24:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-25 08:26:13 EST
This bug has been copied from bug #1284906 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 7 errata-xmlrpc 2016-02-16 05:24:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0177.html

Note You need to log in before you can comment on or make changes to this bug.