Bug 1284935 - weak-module, when adding a module, should collect the symbols from external modules of destination kernel
weak-module, when adding a module, should collect the symbols from external m...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: module-init-tools (Show other bugs)
6.7
x86_64 Linux
medium Severity medium
: rc
: 6.9
Assigned To: Tony Camuso
Robin Hack
Mark Flitter
:
Depends On:
Blocks: 1269194 1318711 1346447 1400664 1405173 1296465
  Show dependency treegraph
 
Reported: 2015-11-24 08:51 EST by Renaud Marigny
Modified: 2017-03-21 07:42 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The weak-modules function now checks external symbols before failing a module as not compatible When adding a module with a different version number to the current kernel, weak-modules checks for exported symbols in that kernel. In some cases, the symbols required are provided by other modules. This fix ensures that the symbols provided by other modules are checked before marking the new module as incompatible.
Story Points: ---
Clone Of:
: 1296465 (view as bug list)
Environment:
Last Closed: 2017-03-21 07:42:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.51 KB, text/plain)
2015-11-24 08:56 EST, Renaud Marigny
no flags Details

  None (edit)
Comment 1 Renaud Marigny 2015-11-24 08:56 EST
Created attachment 1098208 [details]
proposed patch
Comment 3 Samantha N. Bueno 2016-01-14 10:26:55 EST
This came in a bit late for 6.8, especially considering that module-init-tools is not on the approved component list. I'm deferring this to 6.9, and we will take a look at it during that time.

Thanks for the patch, as well.
Comment 10 Tony Camuso 2016-10-21 06:31:08 EDT
Patch set has been developed and tested here at Red Hat.
Comment 11 Tony Camuso 2016-10-25 12:47:04 EDT
Test rpm available at :
http://people.redhat.com/tcamuso/module-init-tools/module-init-tools-3.9-26.el6.x86_64.rpm

Please let us know if this fixes the problem.
Comment 12 Tony Camuso 2016-10-26 14:50:29 EDT
Please ignore the test rpm listed in comment #11

I'm working on a new one now.
Comment 13 Tony Camuso 2016-10-26 15:25:42 EDT
rpm, src.rpm, and debug rpm for testing.

http://people.redhat.com/tcamuso/module-init-tools/
Comment 17 errata-xmlrpc 2017-03-21 07:42:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0772.html

Note You need to log in before you can comment on or make changes to this bug.