Bug 1296465 - weak-module, when adding a module, should collect the symbols from external modules of destination kernel [NEEDINFO]
weak-module, when adding a module, should collect the symbols from external m...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kmod (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: 7.3
Assigned To: David Shea
Chunyu Hu
:
: 1340054 (view as bug list)
Depends On: 1284935
Blocks: 1364088
  Show dependency treegraph
 
Reported: 2016-01-07 05:35 EST by Renaud Marigny
Modified: 2016-11-29 15:26 EST (History)
7 users (show)

See Also:
Fixed In Version: kmod-20-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1284935
Environment:
Last Closed: 2016-11-03 19:55:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dshea: needinfo? (xiaolli)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2171 normal SHIPPED_LIVE kmod bug fix and enhancement update 2016-11-03 09:16:08 EDT

  None (edit)
Comment 8 Chunyu Hu 2016-09-02 06:42:09 EDT
Verified on 3.10.0-495.el7 and kmod-20-6.el7

[root@dell-per415-02 kinfo]# uname -r
3.10.0-500.el7.x86_64

[root@dell-per415-02 kinfo]# rpm -q kmod
kmod-20-6.el7.x86_64

[root@dell-per415-02 kinfo]# modinfo /usr/lib/modules/3.10.0-500.el7.x86_64/extra/kinfo.ko 
filename:       /usr/lib/modules/3.10.0-500.el7.x86_64/extra/kinfo.ko
author:         Rayne
license:        GPL
rhelversion:    7.3
srcversion:     478C0390C4307BE7CDD4CDE
depends:        base
vermagic:       3.10.0-500.el7.x86_64 SMP mod_unload modversions
 
[root@dell-per415-02 kinfo]# modinfo  /usr/lib/modules/3.10.0-495.el7.x86_64/extra/base.ko 
filename:       /usr/lib/modules/3.10.0-495.el7.x86_64/extra/base.ko
author:         Chunyu Hu <chuhu@redhat.com>
license:        GPL
rhelversion:    7.3
srcversion:     809CE6EF0F8F463555BA2C6
depends:        
vermagic:       3.10.0-495.el7.x86_64 SMP mod_unload modversions 
parm:           dummy:How long will the hung task block. (int)

[root@dell-per415-02 kinfo]# ls /usr/lib/modules/3.10.0-500.el7.x86_64/weak-updates/
event_mod  oracleasm

[root@dell-per415-02 kinfo]# ls /usr/lib/modules/3.10.0-495.el7.x86_64/weak-updates/
oracleasm

[root@dell-per415-02 kinfo]# echo /usr/lib/modules/3.10.0-500.el7.x86_64/extra/kinfo.ko  | weak-modules --add-modules --no-initramfs
[root@dell-per415-02 kinfo]# ls /usr/lib/modules/3.10.0-495.el7.x86_64/weak-updates/
kinfo.ko  oracleasm
Comment 11 errata-xmlrpc 2016-11-03 19:55:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2171.html
Comment 12 Chris Williams 2016-11-29 15:26:15 EST
*** Bug 1340054 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.