Bug 1285008 - xflock4 script never matches available screen locking programs from EPEL 7
xflock4 script never matches available screen locking programs from EPEL 7
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: xfce4-session (Show other bugs)
epel7
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 11:25 EST by Jesse Connell
Modified: 2015-12-28 16:25 EST (History)
2 users (show)

See Also:
Fixed In Version: xfce4-session-4.10.1-8.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 16:25:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 10217 None None None Never

  None (edit)
Description Jesse Connell 2015-11-24 11:25:30 EST
Description of problem:

/usr/bin/xflock4 from package xfce4-session lists two possible screensaver programs to use for screen locking, but neither of these are available in any other RHEL or EPEL package currently, as shown in this snippet:

for lock_cmd in \
    "xscreensaver-command -lock" \
    "gnome-screensaver-command --lock"
do
    $lock_cmd >/dev/null 2>&1 && exit
done

Installing the MATE desktop packages and manually adding mate-screensaver-command to the list in the script works fine, as would be expected for a branch of Gnome 2.


Version-Release number of selected component (if applicable):  xfce4-session-0:4.10.1-7.el7.x86_64

How reproducible: Always

Steps to Reproduce:
1. Log in graphically with XFCE desktop chosen
2. Click on the Action Buttons on the panel (that by default is showing the current user on the upper right of the screen)
3. Click "Lock Screen"

Actual results: Nothing happens

Expected results: X session locks

Additional info:

These reports look related to me:

https://bugzilla.redhat.com/show_bug.cgi?id=1166227
https://bugzilla.xfce.org/show_bug.cgi?id=10217
https://bugzilla.xfce.org/show_bug.cgi?id=8993
Comment 1 Kevin Fenzi 2015-11-27 13:46:24 EST
Right, we should be able to use the same fix/patch from 1166227 which should allow a xfconf setting to set whatever lock program you want to use.
Comment 2 Kevin Fenzi 2015-12-05 14:38:19 EST
Can you try this scratch build?

https://koji.fedoraproject.org/koji/taskinfo?taskID=12073821

It should alow you to set whatever lock screen program you want via xfconf...
Comment 3 Jesse Connell 2015-12-11 15:26:25 EST
Thanks Kevin, I can confirm that it works for me by setting the xfconf property /general/LockCommand to "mate-screensaver-command --lock".
Comment 4 Fedora Update System 2015-12-12 12:40:59 EST
xfce4-session-4.10.1-8.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-98507d0250
Comment 5 Fedora Update System 2015-12-14 07:18:59 EST
xfce4-session-4.10.1-8.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update xfce4-session'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-98507d0250
Comment 6 Fedora Update System 2015-12-28 16:25:16 EST
xfce4-session-4.10.1-8.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.