Bug 1285020 - /usr/lib64/ladspa/sifter_1210.so: undefined symbol: q_sort
Summary: /usr/lib64/ladspa/sifter_1210.so: undefined symbol: q_sort
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ladspa-swh-plugins
Version: 23
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orcan Ogetbil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1284604
TreeView+ depends on / blocked
 
Reported: 2015-11-24 16:57 UTC by Jérôme Audu
Modified: 2016-02-26 07:23 UTC (History)
6 users (show)

Fixed In Version: ladspa-swh-plugins-0.4.15-26.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-26 07:23:50 UTC


Attachments (Terms of Use)
update .spec to fix gcc5 inline issue (1.48 KB, patch)
2015-11-24 16:58 UTC, Jérôme Audu
no flags Details | Diff
gcc5 inline fix to avoid "undefined symbol: q_sort" (434 bytes, patch)
2015-11-24 17:01 UTC, Jérôme Audu
no flags Details | Diff

Description Jérôme Audu 2015-11-24 16:57:26 UTC
Description of problem:

Apps like "rosegarden" crash (x86_64 only) during LADSPA discover plugin
due to an undefined symbol: q_sort in /usr/lib64/ladspa/sifter_1210.so: 

Version-Release number of selected component (if applicable):
ladspa-swh-plugins-0.4.15-24.fc23.x86_64.rpm

How reproducible:
Just start "rosegarden" in x86_64

Steps to Reproduce:
1. dnf install rosegarden
2. rosegarden
3.

Actual results:
WARNING: LADSPAPluginFactory::discoverPlugins: couldn't dlopen /usr/lib64/ladspa/sifter_1210.so - /usr/lib64/ladspa/sifter_1210.so: undefined symbol: q_sort
LADSPAPluginFactory::discoverPlugins - done
Erreur de segmentation (core dumped)


Expected results:
no crash

Additional info:

Seem due to gcc5 which does not support recursive inline functions
source: https://github.com/swh/ladspa/commit/93e8a911c95d43016754484d91eec78ef6a80a61

Comment 1 Jérôme Audu 2015-11-24 16:58:51 UTC
Created attachment 1098277 [details]
update .spec to fix gcc5 inline issue

Comment 2 Jérôme Audu 2015-11-24 17:01:21 UTC
Created attachment 1098279 [details]
gcc5 inline fix to avoid "undefined symbol: q_sort"

Patch based on https://github.com/swh/ladspa/commit/93e8a911c95d43016754484d91eec78ef6a80a61

Comment 3 Lorenzo 2015-11-24 21:52:40 UTC
Confirmed on F23 Xfce x86_64.

Comment 4 Francesco Frassinelli (frafra) 2016-01-31 10:50:29 UTC
$ sed -i 's/.orig//g' swh-plugins-0.4.15-inline-qsort.patch
$ sed -i 's/\(BuildRequires:.*\)/\1 perl-XML-Parser/' ladspa-swh-plugins.spec

Koji build: http://koji.fedoraproject.org/koji/taskinfo?taskID=12755976
RPMS: https://kojipkgs.fedoraproject.org//work/tasks/5979/12755979/
SRPM: https://frafra.fedorapeople.org/srpm/ladspa-swh-plugins-0.4.15-26.fc23.src.rpm

Maybe https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers should be followed.

Comment 5 Fedora Update System 2016-02-15 05:39:42 UTC
ladspa-swh-plugins-0.4.15-26.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a86470824

Comment 6 Orcan Ogetbil 2016-02-15 05:43:34 UTC
As the previous maintainer, I took the liberty to push the fix. 

The packaged version of this software seems quite old, from 2007. The current maintainer could consider contacting upstream and ask about the stability of their git, which is actively maintained. The last time I talked to them (4-5 years ago?), they advised me not to package the git as it was unstable, but things might have changed since.

Thank you for all the patches.

Comment 7 Fedora Update System 2016-02-17 06:29:45 UTC
ladspa-swh-plugins-0.4.15-26.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a86470824

Comment 8 Fedora Update System 2016-02-26 07:23:47 UTC
ladspa-swh-plugins-0.4.15-26.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.