Bug 1285067 - (python-pyxid) Review Request: python-pyxid - Python library for interfacing with Cedrus XID and StimTracker devices
Review Request: python-pyxid - Python library for interfacing with Cedrus XID...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Zbigniew Jędrzejewski-Szmek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-neuro
  Show dependency treegraph
 
Reported: 2015-11-24 14:33 EST by Igor Gnatenko
Modified: 2015-12-05 20:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-05 20:22:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
zbyszek: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Igor Gnatenko 2015-11-24 14:33:45 EST
Spec URL: https://ignatenkobrain.fedorapeople.org/neurofedora/python-pyxid.spec
SRPM URL: https://ignatenkobrain.fedorapeople.org/neurofedora/python-pyxid-1.1-0.1.gitc84afe9.fc24.src.rpm
Description:
Python library for interfacing with Cedrus XID and StimTracker devices.

XID (eXperiment Interface Device) devices are used in software such as
SuperLab, Presentation, and ePrime for receiving input as part of
stimulus/response testing experiments.
Fedora Account System Username: ignatenkobrain
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-11-24 16:40:09 EST
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "BSD (3 clause)", "Unknown or generated". 9 files have unknown
     license. Detailed output of licensecheck in /var/tmp/1285067-python-
     pyxid/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package requires other packages for directories it uses.
     Note: No known owner of /usr/lib/python3.5/site-packages,
     /usr/lib/python3.5
(OK, not needed.)

[x]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/lib/python3.5/site-
     packages, /usr/lib/python3.5
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 20480 bytes in 2 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Python:
[x]: Python eggs must not download any dependencies during the build
     process.
[x]: A package which is used by another package via an egg interface should
     provide egg info.
[x]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in
     python2-pyxid , python3-pyxid
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
No upstream test suite.

[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: python2-pyxid-1.1-0.1.gitc84afe9.fc24.noarch.rpm
          python3-pyxid-1.1-0.1.gitc84afe9.fc24.noarch.rpm
          python-pyxid-1.1-0.1.gitc84afe9.fc24.src.rpm
python2-pyxid.noarch: W: spelling-error %description -l en_US eXperiment -> experiment, experiments
python2-pyxid.noarch: W: spelling-error %description -l en_US ePrime -> e Prime, prime, primmer
python3-pyxid.noarch: W: spelling-error %description -l en_US eXperiment -> experiment, experiments
python3-pyxid.noarch: W: spelling-error %description -l en_US ePrime -> e Prime, prime, primmer
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/__init__.cpython-35.opt-1.pyc
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/internal.cpython-35.opt-1.pyc
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/pyxid_impl.cpython-35.opt-1.pyc
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/keymaps.cpython-35.opt-1.pyc
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/serial_wrapper.cpython-35.opt-1.pyc
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/constants.cpython-35.opt-1.pyc
python-pyxid.src: W: spelling-error %description -l en_US eXperiment -> experiment, experiments
python-pyxid.src: W: spelling-error %description -l en_US ePrime -> e Prime, prime, primmer
3 packages and 0 specfiles checked; 0 errors, 12 warnings.

All OK.


Rpmlint (installed packages)
----------------------------
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/keymaps.cpython-35.opt-1.pyc
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/internal.cpython-35.opt-1.pyc
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/pyxid_impl.cpython-35.opt-1.pyc
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/__init__.cpython-35.opt-1.pyc
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/constants.cpython-35.opt-1.pyc
python3-pyxid.noarch: W: python-bytecode-without-source /usr/lib/python3.5/site-packages/pyxid/__pycache__/serial_wrapper.cpython-35.opt-1.pyc
2 packages and 0 specfiles checked; 0 errors, 6 warnings.

All OK.

Requires
--------
python3-pyxid (rpmlib, GLIBC filtered):
    python(abi)
    python3-pyserial

python2-pyxid (rpmlib, GLIBC filtered):
    pyserial
    python(abi)


Provides
--------
python3-pyxid:
    python3-pyxid

python2-pyxid:
    python-pyxid
    python-pyxid(x86-64)
    python2-pyxid

Package is APPROVED.
Comment 2 Till Maas 2015-11-26 15:18:08 EST
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/python-pyxid
Comment 3 Fedora Update System 2015-11-26 18:04:41 EST
python-pyxid-1.1-0.1.gitc84afe9.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-3bf0ebf1dc
Comment 4 Fedora Update System 2015-11-27 21:20:29 EST
python-pyxid-1.1-0.1.gitc84afe9.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-pyxid'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-3bf0ebf1dc
Comment 5 Fedora Update System 2015-12-05 20:22:42 EST
python-pyxid-1.1-0.1.gitc84afe9.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.