Bug 128507 - perl-5.8.5-1 - dependencies mixup
perl-5.8.5-1 - dependencies mixup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
: 128545 128574 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-23 15:47 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-24 14:30:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-07-23 15:47:45 EDT
Description of problem:

Installation of perl-5.8.5-1, at least on x86_64 and I did not check
i386 yet, required '--nodeps' because:

# rpm -V perl
Unsatisfied dependencies for perl-5.8.5-1: perl(Carp::Heavy)

OTOH
# rpm -ql perl | grep Carp/H
/usr/lib/perl5/5.8.5/Carp/Heavy.pm

and the file in question is indeed there the same way as in
previous versions but (Carp::Heavy) is not on "provides" list.

Version-Release number of selected component (if applicable):
perl-5.8.5-1
Comment 1 Chip Turner 2004-07-24 14:30:52 EDT
looks like the dep appeared in the upgrade to 5.8.5.  fixed, should
show up in 5.8.5-2 or later.
Comment 2 Chip Turner 2004-07-26 07:47:42 EDT
*** Bug 128545 has been marked as a duplicate of this bug. ***
Comment 3 Chip Turner 2004-07-26 12:41:24 EDT
*** Bug 128574 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.