Bug 128545 - unresolved self dependency for perl(Carp::Heavy)
unresolved self dependency for perl(Carp::Heavy)
Status: CLOSED DUPLICATE of bug 128507
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-24 22:20 EDT by Arenas Belon, Carlo Marcelo
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arenas Belon, Carlo Marcelo 2004-07-24 22:20:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7)
Gecko/20040718 Firefox/0.9.1

Description of problem:
installing/updating rpm for perl with up2date aborts with message :

  perl  5.8.5-1                            requires perl(Carp::Heavy)

Version-Release number of selected component (if applicable):
perl-5.8.5-1

How reproducible:
Always

Steps to Reproduce:
1. install fedora core 3 test 1 (i am using x86_64, but it is not arch
specific)
2. up2date -u perl
3.
    

Actual Results:  error

Expected Results:  package updated

Additional info:

adding:

  Provides: perl(Carp::Heavy)

to the SPEC and rebuilding fixes the problem, Carp::Heavy is an
internally used module for perl 5.8 as detailed on :

  http://www.perldoc.com/perl5.8.4/lib/Carp/Heavy.html
Comment 1 Chip Turner 2004-07-26 07:47:39 EDT

*** This bug has been marked as a duplicate of 128507 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.