Bug 128508 - system-config-date missing console date utility
system-config-date missing console date utility
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
: FutureFeature
: 129319 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-23 15:54 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 12:40:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-07-23 15:54:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
The system-config-date package has no utility for setting the date on
the console. Looking at the code for system-config-date.py, I see this:

def useGuiMode(page):
    try:
        import mainWindow
    except:
        #Starting the GUI failed, so let's start the text mode UI
        import timeconfig

        sys.exit(0)

Yep, it starts the time setting window! This was supposed to be the
date setting utility. Shouldn't this say 'import dateconfig'.
Shouldn't there be a dateconfig?

Version-Release number of selected component (if applicable):
system-config-date-1.7.3-3

How reproducible:
Always

Steps to Reproduce:
1. /usr/bin/python2 /usr/share/system-config-date/system-config-date.py

Actual Results:  Time setting window pops up

Expected Results:  Date setting window pops up

Additional info:
Comment 1 Nils Philippsen 2004-07-29 10:14:27 EDT
Yes, the text UI should probably allow for setting the date as well.
Marking this as RFE.
Comment 2 Steve Grubb 2004-07-29 12:19:07 EDT
Thanks for looking at this Nils. I don't care how its marked as long
as there's some honesty about the program's actions. I think I would
have put up a "Not implemented yet" message instead of calling the
wrong program.

Also, the timeconfig tui program only sets the timezone...which is
helpful, but not complete. Nowhere in it can you set the time. Should
this be another bug report?
Comment 3 Nils Philippsen 2004-08-06 10:47:15 EDT
No need for another bug report -- I'll use this one as the "text
versions of redhat-/system-config-date seriously lack functionality"
umbrella bug.
Comment 4 Nils Philippsen 2004-08-06 10:47:59 EDT
*** Bug 129319 has been marked as a duplicate of this bug. ***
Comment 5 Nils Philippsen 2006-02-27 12:40:12 EST
This RFE has been open without action for a long time. Closing as DEFERRED to
reflect the actual situation.
Comment 6 illtud 2006-02-27 12:47:26 EST
I'm unhappy that this is being closed deferred. From my experience that means it
won't be fixed. The TUI applications *are* important (go on an RH cert course
and see).
Comment 7 Ricky Ng-Adam 2007-04-28 14:41:02 EDT
Unbelievable, but in FC7 test 4 all we get is a:

Text mode is deprecated

And then the console switches to a white on blue with the following traceback:

Traceback (most recent call last):
                                    File
"/usr/share/system-config-date/system-config-date.py", line 82, in <module>
                                        useGuiMode(page)
                                                          File
"/usr/share/system-config-date/system-config-date.py", line 54, in useGuiMode
                                                                import timeconfig
   File "/usr/share/system-config-date/timeconfig.py", line 106, in <module>
                                                                               
rc = TimezoneWindow()(screen, zonetab, timezoneBackend)
                                                         File
"/usr/share/system-config-date/timeconfig.py", line 60, in __call__
                                                     l.setCurrent(self.default)
                                                                               
 File "/usr/lib/python2.5/site-packages/snack.py", line 185, in setCurrent
                                                                             
self.w.listboxSetCurrent(self.item2key[item])
                                           KeyError: 'America/New_York'
Comment 8 Nils Philippsen 2007-04-28 16:29:41 EDT
Oops. I've updated the timezone handling so timezones in the UI don't include
the underscores that the files beneath /usr/share/zoneinfo have and it seems I
have forgotten about (yeah, totally neglected) the text mode tool.

I think I've fixed it in upstream CVS. Due to the devel freeze I'll be
rebuilding the package only one further time mid next week (barring unexpected
issues), so you'd need to check out the CVS version:

1.) Log into anonymous CVS with an empty password (just hit return):
cvs -d :pserver:anonymous@rhlinux.redhat.com:/usr/local/CVS login
2.) Check out the current code:
cvs -d :pserver:anonymous@rhlinux.redhat.com:/usr/local/CVS co -z4
system-config-date
3.) change to the system-config-date/src directory
4a.) now you can start the whole thing:
./system-config-date.py
4b.) or only the textmode thing:
./timeconfig.py

Next time please open a separate bugzilla ticket, as this was a regression to be
fixed, not a feature request.

Note You need to log in before you can comment on or make changes to this bug.