Bug 129319 - redhat-config-date text utility doesn't configure ntp
Summary: redhat-config-date text utility doesn't configure ntp
Status: CLOSED DUPLICATE of bug 128508
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-date (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-06 13:07 UTC by illtud
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description illtud 2004-08-06 13:07:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4)
Gecko/20030624

Description of problem:
The preferred way to set up ntp (as a client) on RHEL is to use
'redhat-config-date' (see documentation and /etc/ntp* files). The
text-based version of the tool does nothing more that set the TZ, it
doesn't include the NTP setup which the graphical version does.

Version-Release number of selected component (if applicable):
1.5.22-1

How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-date in text mode
2. Get to choose your TZ. 
3. Click 'next'
    

Actual Results:  Utility ends and hands you back to the shell.

Expected Results:  Some kind of NTP control.

Additional info:

Those of us who prefer to run our servers without X (surely a large
proportion of Enterprise users) expect the text versions of the config
tools to mirror the GUI ones.

Comment 1 Nils Philippsen 2004-08-06 14:47:58 UTC

*** This bug has been marked as a duplicate of 128508 ***

Comment 2 illtud 2004-08-06 15:05:46 UTC
Yes, it's the same bug as 128508, but I'm on RHEL, not Fedora Core,
which is why my search for bugs in redhat-config-date in RHEL came up
with zaroo. Can RHEL be added to the systems affected to 128508? If
not, can you keep this bug open, since the bug still exists in RHEL,
and as an Enterprise customer when I'm looking for bugs in RHEL, I
certainly don't search FC bugs (since FC is so far ahead of RHEL).

Comment 3 illtud 2004-08-06 15:10:50 UTC
Another reason to keep this one open is that FC now calls the utility
'system-config-date', so even searching across all RH Products for
'redhat-config-date' (the broken RHEL component) won't lead you to bug
#128508. (I did my best to find this bug in Bugzilla first, honest).

Comment 4 Nils Philippsen 2004-08-06 16:04:07 UTC
I didn't expect you to spot this on your own in the first place ;-).

The reasons why I dupe-closed this one are:
- this is really the same bug, despite the tools being named differently
- now I have a reference on the system-config-date bug to this bug,
meaning if I come around to implementing the requested functionality
in the development version I shouldn't forget about the same issue in RHEL
- I can always reopen this bug once this is implemented in
system-config-date to backport the implementation

Mind that you will be kept up to date on the other bugs progress as
Bugzilla has put you into the Cc: list for it.

Comment 5 Red Hat Bugzilla 2006-02-21 19:05:01 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.