Bug 1285137 - [abrt] xorg-x11-server-Xorg: Segmentation fault at address 0x200000
[abrt] xorg-x11-server-Xorg: Segmentation fault at address 0x200000
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
abrt_hash:8851182aa71ab8085a3c846f395...
:
: 1284726 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 21:35 EST by dosboss64
Modified: 2015-12-04 15:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 15:47:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: Xorg.0.log (37.27 KB, text/plain)
2015-11-24 21:35 EST, dosboss64
no flags Details
File: backtrace (828 bytes, text/plain)
2015-11-24 21:35 EST, dosboss64
no flags Details
File: dmesg (86.25 KB, text/plain)
2015-11-24 21:35 EST, dosboss64
no flags Details
File: dso_list (238 bytes, text/plain)
2015-11-24 21:35 EST, dosboss64
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (405 bytes, application/octet-stream)
2015-11-24 21:35 EST, dosboss64
no flags Details
File: usr_share_xorg_conf_d.tar.gz (2.28 KB, application/octet-stream)
2015-11-24 21:35 EST, dosboss64
no flags Details

  None (edit)
Description dosboss64 2015-11-24 21:35:38 EST
Description of problem:
- Log in to MATE desktop (F23 MATE spin). through the GDM login page.
- Perform random activity (Open web browser, browse pages, play videos, make congi changes, add icons to desktop, doesn't matter what, it has crashed on *all* different types of activity).
- X crashes (sometimes with interesting character art patterns and color characters across the screen, other times a black screen, but always a black console background), restarts GDM and dumps you to the graphical login prompt.

Version-Release number of selected component:
xorg-x11-server-Xorg-1.18.0-2.fc23

Additional info:
reporter:       libreport-2.6.3
executable:     /usr/bin/X
kernel:         4.2.6-300.fc23.x86_64
runlevel:       N 5
type:           xorg

Truncated backtrace:
0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x59afb9]
1: /lib64/libc.so.6 (__restore_rt+0x0) [0x7fd7dcb49b1f]
2: /lib64/libpixman-1.so.0 (pixman_region_selfcheck+0xc) [0x7fd7ddcb3aec]
3: /lib64/libpixman-1.so.0 (pixman_region_fini+0x9) [0x7fd7ddcb3c89]
4: /usr/libexec/Xorg (RegionDestroy+0x9) [0x458669]
5: /usr/libexec/Xorg (SwapShorts+0x3913) [0x465993]
6: /usr/libexec/Xorg (DeleteWindow+0x70) [0x465240]
7: /usr/libexec/Xorg (RegisterResourceName+0x232) [0x45b2e2]
8: /usr/libexec/Xorg (FreeResource+0xd9) [0x45bd49]
9: /usr/libexec/Xorg (ProcBadRequest+0x389) [0x430e39]
10: /usr/libexec/Xorg (SendErrorToClient+0x2df) [0x4369bf]
11: /usr/libexec/Xorg (remove_fs_handlers+0x453) [0x43a9e3]
12: /lib64/libc.so.6 (__libc_start_main+0xf0) [0x7fd7dcb35580]
13: /usr/libexec/Xorg (_start+0x29) [0x424ce9]
14: ? (?+0x29) [0x29]
Comment 1 dosboss64 2015-11-24 21:35:40 EST
Created attachment 1098481 [details]
File: Xorg.0.log
Comment 2 dosboss64 2015-11-24 21:35:41 EST
Created attachment 1098482 [details]
File: backtrace
Comment 3 dosboss64 2015-11-24 21:35:43 EST
Created attachment 1098483 [details]
File: dmesg
Comment 4 dosboss64 2015-11-24 21:35:44 EST
Created attachment 1098484 [details]
File: dso_list
Comment 5 dosboss64 2015-11-24 21:35:45 EST
Created attachment 1098485 [details]
File: etc_X11_xorg_conf_d.tar.gz
Comment 6 dosboss64 2015-11-24 21:35:46 EST
Created attachment 1098486 [details]
File: usr_share_xorg_conf_d.tar.gz
Comment 7 dosboss64 2015-11-24 21:55:41 EST
*** Bug 1284726 has been marked as a duplicate of this bug. ***
Comment 8 dosboss64 2015-11-24 22:24:43 EST
I had another crash today, exact same outcome. I published it through ABRT as bugzilla # 1285137.  I closed that one as a duplicate of this one when I realized what ABRT did.

Short synopsis of what I was doing at the time of the (newer) crash:
- Opened Firefox and about 16 tabs. None had Flash content to my knowledge, still going through the pages to see but haven't found anything amiss.
- Had three terminal windows open (F23 MATE desktop).
- I had just done a dnf update.
- I right-clicked the Google Chrome icon I had just placed on the top menu bar, and selected "Properties" - instant X crash.

- None of the above is duplicate between crashes, except for having a terminal window open.

- I now have 6 of these crashes in ABRT since installing F23 on Saturday. All were during user activity, none occurred when I was away from the machine (I tend to leave myself logged in for months at a time, unless there's a kernel update)

On my home system I just came from an old AMD 2.4GHz/Nvidia machine (HP Pavillion a1710n hardware, lately running F20), and never experienced these issues. As a matter of fact, I have not experienced these issues since FC3 on that old machine (yes, I have been on Fedora for a long time). Just to let you know my experience level, I have built from scratch/installed and administered Fedora, RHEL, RH, CentOS, WBL, Oracle Linux, OpenSolaris (not to mention the real thing, versions 8 through 11), Mandrake, Slackware, Mandriva, SUSE, Debian, Free/Net/BSD, minix, Gentoo, AIX, HPUX, and a host of other distros/proprietary UNIX on tons of hardware that I can't even recount over the last 20+ years (being a sysadmin hath its privileges). I built this machine with compatible parts and ran several tests on RAM and processor before installing the OS. I have tested both with, and without a mild overclock on the processor (4.1GHZ on 3.9GHz APU) and the RAM (SPD detects DDR3-1333, this is DDR3-2400 certified and I run it as such).

Since there is a Fedora Forum post on this issue with several different types of hardware configurations. I really don't think hardware is at fault. I am getting frustrated with the crashes. I am looking at downgrading X.org right now to see if this resolves anything.
Comment 9 dosboss64 2015-11-24 22:39:25 EST
I just downgraded and restarted the X subsystems (telinit 3, telinit 5 from console):

dnf downgrade xorg-x11-server-Xorg.x86_64 xorg-x11-server-common.x86_64
.....
Downgraded:
  xorg-x11-server-Xorg.x86_64 1.18.0-0.4.20150907.fc23                                    xorg-x11-server-common.x86_64 1.18.0-0.4.20150907.fc23                                   

Complete!

# dnf downgrade xorg-x11-server-Xorg.x86_64 xorg-x11-server-common.x86_64
Last metadata expiration check performed 0:12:13 ago on Tue Nov 24 22:17:10 2015.
Package xorg-x11-server-Xorg of lowest version already installed, cannot downgrade it.
Package xorg-x11-server-common of lowest version already installed, cannot downgrade it.
Error: Nothing to do.

As you can see, I was only on the first updated version available from the updates repo, downgrading took me to the install default version.

I then logged in, opened Firefox, then Thunderbird, then entered my password for the password database in TB, pressed <ENTER> - immediate crash.

I then logged in again, did the exact same steps, and added on opening two terminal windows. I am now typing this in Firefox on that system, and it hasn't decided to crash yet.

Since downgrading did not solve anything, I am going back to the updates latest version.
Comment 10 dosboss64 2015-11-27 00:18:53 EST
Well, I went back to the latest X.org packages and the problem seems to have gone away. I am still not closing this as it has only been a little over 3 days now, and I am still not sure what caused the issue in the first place. Since I upgraded, I have run some intensive testing, like running dieharder with all tests selected in four separate terminals (one for each processor, since the program is not multithreaded), running 10 separate YouTube HD 1080P videos in Chrome (HTML5 mode) at the same time while rapidly switching back and forth between those tabs, running a couple games at full settings to tax the GPUs, as well as running a few instances of glxgears concurrently.

I will close this in a week if nothing further develops.
Comment 11 dosboss64 2015-12-04 15:47:44 EST
Nothing further has happened, despite using the graphics capabilities to a great extent (ie GIMP with tons of pics open, running 3-d games through Wine/DirectX 12, playing several movies at max resolution, fullscreen and not, etc). Since I have not experienced further problems I am closing this ticket.

Note You need to log in before you can comment on or make changes to this bug.