Bug 1285273 - Self Service UI: When display Catalog Name in Filter, Catalogs are not in alphabetic order
Self Service UI: When display Catalog Name in Filter, Catalogs are not in alp...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Aparna Karve
Niyaz Akhtar Ansari
:
Depends On:
Blocks: 1289651
  Show dependency treegraph
 
Reported: 2015-11-25 05:32 EST by Loic Avenel
Modified: 2016-06-29 11:11 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289651 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:11:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen Shots (45.06 KB, image/png)
2015-11-25 05:32 EST, Loic Avenel
no flags Details
Catalog Name Filter in self service UI (16.10 KB, image/png)
2016-04-18 03:15 EDT, Niyaz Akhtar Ansari
no flags Details

  None (edit)
Description Loic Avenel 2015-11-25 05:32:23 EST
Created attachment 1098695 [details]
Screen Shots

Description of problem: When display Catalog Name in Filter, Catalogs are not in alphabetic order


Version-Release number of selected component (if applicable):


How reproducible: Every Time


Steps to Reproduce:
1. Log to Self-Service UI
2. Got to Service Catalog
3. Select "Catalog Name" as filter
4. show all Catalog

Actual results:

Catalog Name are not in Alphabetic order

Expected results:


Additional info:
Comment 2 Loic Avenel 2015-11-25 06:12:16 EST
Version is: 4.0 RC1
Comment 4 CFME Bot 2015-12-17 18:21:29 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/6a6cc1c146ad57431f583d2e9f69d792eff50be1

commit 6a6cc1c146ad57431f583d2e9f69d792eff50be1
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Tue Dec 15 10:29:57 2015 -0800
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Wed Dec 16 15:28:17 2015 -0800

    Use REST API 'sort_by' & 'sort_options' params to sort the catalog list
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1285273

 .../app/resources/collections-api.factory.js       |  8 ++++++++
 .../app/states/marketplace/list/list.state.js      | 23 ++++++++++++++--------
 2 files changed, 23 insertions(+), 8 deletions(-)
Comment 5 Dmitry Misharov 2016-01-19 07:22:44 EST
Verified fixed in 5.5.2.1.20160114044944_395c086. Catalogs list is sorted in alphabetic order.
Comment 6 Jan Krocil 2016-01-19 09:08:56 EST
The comment above was meant for a different BZ. Reverting back to MODIFIED.
Comment 7 Niyaz Akhtar Ansari 2016-04-18 03:11:43 EDT
Catalogs list is sorted in alphabetic order in self service UI

Verified in 5.6.0.1-beta2.20160413141124_e25ac0e.
Comment 8 Niyaz Akhtar Ansari 2016-04-18 03:15 EDT
Created attachment 1148112 [details]
Catalog Name Filter in self service UI
Comment 10 errata-xmlrpc 2016-06-29 11:11:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.