Bug 1289651 - Self Service UI: When display Catalog Name in Filter, Catalogs are not in alphabetic order
Self Service UI: When display Catalog Name in Filter, Catalogs are not in alp...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.2
Assigned To: Aparna Karve
Dmitry Misharov
: ZStream
Depends On: 1285273
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 11:27 EST by John Prause
Modified: 2016-02-10 10:26 EST (History)
8 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285273
Environment:
Last Closed: 2016-02-10 10:26:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2015-12-18 17:49:05 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=7bca548e00aaf89e9fb66753d54a671dc791a88f

commit 7bca548e00aaf89e9fb66753d54a671dc791a88f
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Tue Dec 15 10:29:57 2015 -0800
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Fri Dec 18 12:47:20 2015 -0800

    Use REST API 'sort_by' & 'sort_options' params to sort the catalog list
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289651

 .../app/resources/collections-api.factory.js       |  8 ++++++++
 .../app/states/marketplace/list/list.state.js      | 23 ++++++++++++++--------
 2 files changed, 23 insertions(+), 8 deletions(-)
Comment 3 CFME Bot 2015-12-18 17:49:09 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=9c91c55a7e7717dd74ac3801078735fbe47058e6

commit 9c91c55a7e7717dd74ac3801078735fbe47058e6
Merge: ce24397 7bca548
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Dec 18 17:36:38 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Dec 18 17:36:38 2015 -0500

    Merge branch 'ssui_catalogs_sort' into '5.5.z'
    
    Use REST API 'sort_by' & 'sort_options' params to sort the catalog list
    
    Clean cherry-pick
    Upstream PR - https://github.com/ManageIQ/manageiq/pull/5866
    
    Use REST API ```sort_by``` and ```sort_options=ignore_case``` parameters to sort the catalog list
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289651
    
    See merge request !647

 .../app/resources/collections-api.factory.js       |  8 ++++++++
 .../app/states/marketplace/list/list.state.js      | 23 ++++++++++++++--------
 2 files changed, 23 insertions(+), 8 deletions(-)
Comment 5 Dmitry Misharov 2016-01-19 08:56:53 EST
Verified fixed in 5.5.2.1.20160114044944_395c086. Catalogs list is sorted in alphabetic order.
Comment 6 errata-xmlrpc 2016-02-10 10:26:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.