This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1285314 - Packstack needs to support aodh services since Mitaka
Packstack needs to support aodh services since Mitaka
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: Milestone1
: trunk
Assigned To: Javier Peña
Shai Revivo
: Triaged
: 1289667 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 06:50 EST by Javier Peña
Modified: 2016-06-17 09:36 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-packstack-8.0.0-0.4.0rc1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-17 09:36:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 250472 None None None Never
OpenStack gerrit 251988 None None None Never

  None (edit)
Description Javier Peña 2015-11-25 06:50:39 EST
Description of problem: 

The Ceilometer project has moved all alarming code to a separate project (aodh), and there will be no more openstack-ceilometer-alarm-* services starting in Mitaka (see https://review.openstack.org/197161 for more details).

Currently, Packstack sets up ceilometer-alarm-notifier and ceilometer-alarm-evaluator, and this support should be updated to aodh-alarm-notifier and aodh-alarm-evaluator. There is already a puppet-aodh module in OPM, so it should be a relatively straightforward process.
Comment 1 Javier Peña 2015-12-01 12:31:36 EST
Proposed https://review.openstack.org/251988 to add the Aodh support. It also depends on a patch to puppet-aodh (https://review.openstack.org/250472).
Comment 2 David Moreau Simard 2015-12-05 08:25:13 EST
Hey guys, this is a blocker for Mitaka right now. It would be nice to have it fixed in time for the test days December 10th and 11th.

CI jobs are failing with:

172.16.0.232_ceilometer.pp:                       [ ERROR ]
05:36:33 Applying Puppet manifests                         [ ERROR ]
05:36:33 
05:36:33 ERROR : Error appeared during Puppet run: 172.16.0.232_ceilometer.pp
05:36:33 Error: Could not start Service[ceilometer-alarm-notifier]: Execution of '/usr/bin/systemctl start openstack-ceilometer-alarm-notifier' returned 6: Failed to issue method call: Unit openstack-ceilometer-alarm-notifier.service failed to load: No such file or directory.
05:36:33 You will find full trace in log /var/tmp/packstack/20151205-094354-vPBt9o/manifests/172.16.0.232_ceilometer.pp.log
Comment 3 David Moreau Simard 2015-12-05 09:34:49 EST
FYI I applied the patch in the review for aodh support (after installing pymongo manually) and got this error:

192.168.1.214_keystone.pp:                        [ ERROR ]          
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.1.214_keystone.pp
Error: Puppet::Parser::AST::Resource failed with error ArgumentError: Could not find declared class ::aodh::keystone::auth at /var/tmp/packstack/07790ecc71bc4da0802aec628230ef92/manifests/192.168.1.214_keystone.pp:208 on node test-packstack-mitaka.openstacklocal
You will find full trace in log /var/tmp/packstack/20151205-142003-xnD30C/manifests/192.168.1.214_keystone.pp.log

I tried to find where OPM pulls it's dependencies (and failed) but in any case, it looks like we will also need to add the aodh puppet module there as well.
Comment 4 David Moreau Simard 2015-12-05 10:49:52 EST
I confirm that once puppet-aodh is present (and that the mongodb support in aodh is pulled) this lets packstack installation complete on Mitaka.
Comment 5 Alan Pevec 2015-12-08 12:23:52 EST
*** Bug 1289667 has been marked as a duplicate of this bug. ***
Comment 6 Alan Pevec 2015-12-08 12:27:32 EST
From bz 1289667  aodh removes keystone configuration when manifest is applied:

(In reply to Ivan Chavero from comment #5)
> it seems that the aodh puppet module is not calling the apache class with
> the "purge_configs => false" directive, this might be an
> openstack-puppet-modules bug

Please propose the fix here, then we'll evaluate if we merge aodh support in packstack or just drop alarm from mitaka-1 testday.
Comment 7 Ivan Chavero 2015-12-08 13:28:44 EST
Checking a packstack workaround for the purging of apache configurations

FYI, as the gerrit review states, it needs this patch applied on the aodh puppet module: https://review.openstack.org/#/c/250472/1, this patch is merged upstream but hasn't landed on OPM.
Comment 8 Alan Pevec 2015-12-09 15:53:04 EST
For mitaka-1 testday, alarm is temporarily removed in Packstack (same as rdom):
https://review.gerrithub.io/254640
Comment 9 Mike McCune 2016-03-28 18:48:26 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 11 Javier Peña 2016-06-17 09:36:09 EDT
Packstack Mitaka shipped with Aodh support, closing.

Note You need to log in before you can comment on or make changes to this bug.