Bug 1289667 - aodh removes keystone configuration when manifest is applied (resulting in keystone 404's)
aodh removes keystone configuration when manifest is applied (resulting in ke...
Status: CLOSED DUPLICATE of bug 1285314
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: trunk
Assigned To: Martin Magr
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 11:38 EST by David Moreau Simard
Modified: 2016-04-18 02:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 12:23:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example OSC keystone 404 (7.32 KB, text/plain)
2015-12-08 11:39 EST, David Moreau Simard
no flags Details
Puppet excerpt of keystone being set up properly (5.51 KB, text/plain)
2015-12-08 11:39 EST, David Moreau Simard
no flags Details
Puppet excerpt of aodh removing keystone configuration (6.49 KB, text/plain)
2015-12-08 11:40 EST, David Moreau Simard
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 251988 None None None Never

  None (edit)
Description David Moreau Simard 2015-12-08 11:38:40 EST
After a complete mitaka packstack installation, there are no errors from the installation dialog.

However, when I want to use the packstack installation, I sourced the keystonerc file and noticed there would be keystone 404's - therefore I could not do anything.

In Mitaka, both keystone and aodh are set to run as wsgi under Apache.

When the aodh manifest runs, it removes the apache configuration that was previously set for keystone.

This is likely due to be because of the default puppet-apache behavior to purge configuration it doesn't know about. Since keystone and aodh both run in separate manifest files, they each have their own catalog and therefore don't know about each other - resulting in configuration purge.
Comment 1 David Moreau Simard 2015-12-08 11:39 EST
Created attachment 1103649 [details]
Example OSC keystone 404
Comment 2 David Moreau Simard 2015-12-08 11:39 EST
Created attachment 1103650 [details]
Puppet excerpt of keystone being set up properly
Comment 3 David Moreau Simard 2015-12-08 11:40 EST
Created attachment 1103651 [details]
Puppet excerpt of aodh removing keystone configuration
Comment 4 David Moreau Simard 2015-12-08 11:49:56 EST
Ooops, this was found when testing the unmerged review https://review.openstack.org/#/c/251988/.
Comment 5 Ivan Chavero 2015-12-08 12:05:15 EST
it seems that the aodh puppet module is not calling the apache class with the "purge_configs => false" directive, this might be an openstack-puppet-modules bug
Comment 6 Alan Pevec 2015-12-08 12:07:45 EST
(In reply to David Moreau Simard from comment #4)
> Ooops, this was found when testing the unmerged review
> https://review.openstack.org/#/c/251988/.

ok, I'll close is dup of bug 1285314 to keep discussion in one place.
Comment 7 Alan Pevec 2015-12-08 12:23:52 EST

*** This bug has been marked as a duplicate of bug 1285314 ***

Note You need to log in before you can comment on or make changes to this bug.