This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 128543 - cls_u32 doesn't work with iproute2
cls_u32 doesn't work with iproute2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-07-24 17:48 EDT by Nathan G. Grennan
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 01:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2004-07-24 17:48:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040625 Galeon/1.3.16

Description of problem:
I am trying to use wshaper.htb from wondershaper 1.1a, and found any
u32 classifer tc commands don't work. They return "RTNETLINK answers:
Invalid argument". The best I can tell it is caused by changes
introduced by patch-2.6.8-rc1. I also get this error message, "Please
upgrade your iproute2 tools or compile proper options in!". But then
there isn't a newer version of iproute2. They are all years old. I
have also tried downgrading iproute2 to the fc2 version.

Version-Release number of selected component (if applicable):
kernel-2.6.7-1.494

How reproducible:
Always

Steps to Reproduce:
1. ./wshaper.htb
  

Actual Results:  RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument

Expected Results:  No error messages

Additional info:

I have also seen a discussion on fedora-list about this. Someone
mentioned the previous kernel version, 2.6.7-1.492
Comment 1 Nathan G. Grennan 2004-07-24 19:10:03 EDT
Commands from wondershaper:

tc filter add dev $DEV parent 1:0 protocol ip prio 10 u32 match ip tos
0x10 0xff  flowid 1:10
tc filter add dev $DEV parent 1:0 protocol ip prio 10 u32 match ip
protocol 1 0xff flowid 1:10
tc filter add dev $DEV parent 1: protocol ip prio 10 u32 match ip
protocol 6 0xff match u8 0x05 0x0f at 0 match u16 0x0000 0xffc0 at 2
match u8 0x10 0xff at 33 flowid 1:10
Comment 2 Nathan G. Grennan 2004-08-01 12:37:10 EDT
Here is where I found the latest version of iproute2, but it doesn't
help with the errors above.

http://developer.osdl.org/dev/iproute2/download/iproute2-2.6.8-ss040730.tar.gz
Comment 3 Dennis DeDonatis 2004-08-04 10:03:46 EDT
The kernel 2.6.7-1.494.2.2 RPMS built on August 3rd, 2004 as updates 
for FC2 send out this syslog message, too:

kernel: Please upgrade your iproute2 tools or compile proper options 
in!

It happens when I try to do things like:

tc filter add dev tun0 parent 1:0 protocol ip prio 2 u32 \
      match ip sport 22 0xffff flowid 1:10


If I try to add ingress filtering (tc qdisc add dev tun0 handle ffff: 
ingress), I get a *LOT* of these syslog messages:

kernel: ing_filter:  fixed  tun0 out tun0

Comment 4 Marco Varanda 2004-08-06 08:47:01 EDT
The kernel 2.6.7-1.494.2.2 RPMS built on August 3rd, 2004 as updates 
for FC2 send out this syslog message, too:

kernel: Please upgrade your iproute2 tools or compile proper options 
in!

It happens when I try to load cbq rules:

DEVICE=eth0,100Mbit,10Mbit
RATE=30Kbit
WEIGHT=3Kbit
PRIO=4
RULE=****my_real_ip****:25,


This is not a new rule, I already use it about six month

thanks

Comment 5 Dennis DeDonatis 2004-08-09 12:45:10 EDT
This seems to be fixed in the development kernel (kernel-2.6.7-1.509).
Comment 6 Nathan G. Grennan 2004-08-10 01:57:51 EDT
It isn't completely fixed, but is much better. The last command in
wshaper still doesn't work.

tc filter add dev $DEV parent ffff: protocol ip prio 50 u32 match ip
src  0.0.0.0/0 police rate ${DOWNLINK}kbit burst 10k drop flowid :1

RTNETLINK answers: Invalid argument
Comment 7 Kenneth Porter 2004-08-14 20:29:50 EDT
See also bug 129185.
Comment 8 Nathan G. Grennan 2004-08-14 21:52:07 EDT
The problem with the last command in wondershaper seems to be the
police modules being disabled.

kernel-2.6.8-i686.config:# CONFIG_NET_CLS_POLICE is not set
kernel-2.6.8-i686.config:# CONFIG_NET_ACT_POLICE is not set
Comment 9 Rik van Riel 2004-08-14 23:18:26 EDT
Arjan, could you please enable those config options ?

ingress filtering is a critical part of wshaper and people's QoS
scripts (including mine ;)) will stop working if they can't use
ingress filtering...
Comment 10 Nathan G. Grennan 2004-08-14 23:57:05 EDT
I have confirmed that enabled the POLICE options makes wondershaper
work completely again.
Comment 11 Nathan G. Grennan 2004-08-20 01:20:16 EDT
Fixed in the latest kernels

wondershaper works without error again. :)

Note You need to log in before you can comment on or make changes to this bug.