Bug 1285456 - [RFE] Persist column visibility and position in browser's local storage
[RFE] Persist column visibility and position in browser's local storage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
2.1.0
Unspecified Unspecified
medium Severity high
: ovirt-4.2.0
: 4.2.0
Assigned To: Alexander Wels
Pavel Novotny
: FutureFeature, ZStream
Depends On: 1172390
Blocks: 1514899
  Show dependency treegraph
 
Reported: 2015-11-25 11:01 EST by vszocs
Modified: 2018-05-15 13:38 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
In the current release, the Manager's column widths, visibility, and order are persistent.
Story Points: ---
Clone Of:
: 1514899 (view as bug list)
Environment:
Last Closed: 2018-05-15 13:36:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pnovotny: testing_plan_complete+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 83877 master MERGED webadmin: Grid column width persistence. 2017-11-10 06:46 EST
oVirt gerrit 84047 master MERGED webadmin: Persist column visibility 2017-11-13 15:58 EST
oVirt gerrit 84122 master MERGED webadmin: Persist column order 2017-11-16 15:12 EST
oVirt gerrit 84204 ovirt-engine-4.1 MERGED webadmin: Grid column width persistence. 2017-11-17 09:33 EST
oVirt gerrit 84207 ovirt-engine-4.1 MERGED webadmin: Persist column visibility 2017-11-17 09:33 EST
oVirt gerrit 84282 ovirt-engine-4.1 MERGED webadmin: Persist column order 2017-11-19 05:24 EST
Red Hat Product Errata RHEA-2018:1488 None None None 2018-05-15 13:38 EDT

  None (edit)
Description vszocs 2015-11-25 11:01:23 EST
BZ 1172390 introduces table header context menu that allows users to control visibility and position of individual columns for all main & sub tabs.

  https://imgur.com/5dfh8QA

This RFE completes the feature by persisting above mentioned column settings in browser's local storage, similar to persisting other client-side settings.

Implementing this RFE is non-trivial due to interference with existing column width persistence mechanism (which uses column index).
Comment 1 Oved Ourfali 2016-03-03 02:24:31 EST
Vojtech - how much work is left to complete this?
Will we be able to push that in 4.0?
Comment 2 vszocs 2016-03-11 12:45:21 EST
(In reply to Oved Ourfali from comment #1)
> Vojtech - how much work is left to complete this?

The "column control menu" is already implemented, its code is further improved by patch https://gerrit.ovirt.org/#/c/54186/ which also addresses RFE BZ#1285499 to utilize drag'n'drop behavior.

Given that RFE BZ#1285499 already has a fix, this RFE is the only one to fix in order to consider "column control menu" UI feature as complete.

ETA 3-4 days, just need to ensure that existing "persist column widths" mechanism works well with ability to re-arrange column positions.

> Will we be able to push that in 4.0?

Yes, I believe so.
Comment 14 Pavel Novotny 2017-12-15 12:53:51 EST
Verified in
ovirt-engine-4.2.0.2-0.1.el7.noarch
ovirt-engine-webadmin-portal-4.2.0.2-0.1.el7.noarch

The visibility, position and width of individual columns are persistent across sessions or page reloads. The settings are stored in browser's local storage.
Comment 17 errata-xmlrpc 2018-05-15 13:36:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Note You need to log in before you can comment on or make changes to this bug.