Bug 1285463 - The cloud tenant summary page always shows 0 images
The cloud tenant summary page always shows 0 images
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Ladislav Smola
Pavol Kotvan
tenant
:
Depends On:
Blocks: 1289745
  Show dependency treegraph
 
Reported: 2015-11-25 11:20 EST by Bill Wei
Modified: 2016-06-29 11:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.6.0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289745 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:11:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Wei 2015-11-25 11:20:54 EST
Description of problem:
In the summary page of an OpenStack cloud tenant page, the field Images always shows 0.

In the backend this is caused by the query of ManageIQ::Providers::Openstack::CloudManager::CloudTenant.miq_templates returns []. The many_to_many relationship is not handled properly at image collection time.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Ladislav Smola 2016-01-12 02:50:14 EST
this will require getting /v2/images/​{image_id}​/members to refresh that relation
Comment 4 CFME Bot 2016-04-19 01:00:56 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/7f841eed10af19aa5aa0bbc4729db7fd9d6896ea

commit 7f841eed10af19aa5aa0bbc4729db7fd9d6896ea
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Wed Mar 16 17:26:20 2016 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Tue Apr 12 11:05:29 2016 +0200

    OpenStack fix tenant <-> image membership
    
    Fixing tenant <-> image membership taking in account if
    image is public and members of the image.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1285463

 app/models/ems_refresh/save_inventory.rb              |  2 ++
 .../openstack/refresh_parser_common/images.rb         | 19 ++++++++++++++++++-
 2 files changed, 20 insertions(+), 1 deletion(-)
Comment 8 errata-xmlrpc 2016-06-29 11:11:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.