Bug 1289745 - The cloud tenant summary page always shows 0 images
The cloud tenant summary page always shows 0 images
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.4
Assigned To: Ladislav Smola
Pavol Kotvan
: ZStream
Depends On: 1285463
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 16:12 EST by John Prause
Modified: 2016-05-31 09:40 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.5.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285463
Environment:
Last Closed: 2016-05-31 09:40:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 CFME Bot 2016-04-22 14:03:46 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=4c8825ee7a57007bff25abc238421e0336bea4d1

commit 4c8825ee7a57007bff25abc238421e0336bea4d1
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Wed Mar 16 17:26:20 2016 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Tue Apr 19 16:59:56 2016 +0200

    OpenStack fix tenant <-> image membership
    
    Fixing tenant <-> image membership taking in account if
    image is public and members of the image.
    
    Fixes 5.5.z BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1289745
    
    Cherry-picked commit 7f841eed10af19aa5aa0bbc4729db7fd9d6896ea from:
    https://github.com/ManageIQ/manageiq/pull/7326
    
    Conflicts:
    	app/models/manageiq/providers/openstack/refresh_parser_common/images.rb

 app/models/ems_refresh/save_inventory.rb                |  2 ++
 .../providers/openstack/refresh_parser_common/images.rb | 17 +++++++++++++++++
 2 files changed, 19 insertions(+)
Comment 5 CFME Bot 2016-04-22 14:03:55 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=9810417e83ffea0321fb5b711556e6c68e3460ac

commit 9810417e83ffea0321fb5b711556e6c68e3460ac
Merge: ccc2a69 36067e7
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Fri Apr 22 13:39:19 2016 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Fri Apr 22 13:39:19 2016 -0400

    Merge branch 'bz1289745' into '5.5.z'
    
    Bz1289745
    
    OpenStack fix tenant <-> image membership
    
    Fixing tenant <-> image membership taking in account if
    image is public and members of the image.
    
    Fixes 5.5.z BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1289745
    
    Cherry-picked commit 7f841eed10af19aa5aa0bbc4729db7fd9d6896ea from:
    https://github.com/ManageIQ/manageiq/pull/7326
    
    Conflicts:
     app/models/manageiq/providers/openstack/refresh_parser_common/images.rb
    
    And manually edited VCRs with image/members calls
    
    
    See merge request !902

 app/models/ems_refresh/save_inventory.rb           |   2 +
 .../openstack/refresh_parser_common/images.rb      |  17 +
 .../cloud_manager/refresher_rhos_grizzly.yml       | 320 +++++++++----
 .../cloud_manager/refresher_rhos_havana.yml        | 492 ++++++++++++--------
 .../cloud_manager/refresher_rhos_icehouse.yml      | 492 ++++++++++++--------
 .../cloud_manager/refresher_rhos_juno.yml          | 508 +++++++++++++--------
 .../cloud_manager/refresher_rhos_kilo.yml          | 508 +++++++++++++--------
 .../refresher_rhos_kilo_keystone_v3.yml            | 132 ++++++
 8 files changed, 1641 insertions(+), 830 deletions(-)
Comment 10 errata-xmlrpc 2016-05-31 09:40:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1101

Note You need to log in before you can comment on or make changes to this bug.