Bug 1285544 - python-feedcache: Missing "python2-<module>" provides
python-feedcache: Missing "python2-<module>" provides
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-feedcache (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On: 1335144
Blocks: 1282146
  Show dependency treegraph
 
Reported: 2015-11-25 17:20 EST by William Moreno
Modified: 2016-12-05 16:41 EST (History)
6 users (show)

See Also:
Fixed In Version: python-feedcache-1.4.1-5.fc26 python-feedcache-1.4.1-5.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-05 16:41:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
provide python2-feedcache and modernize SPEC (2.38 KB, patch)
2016-07-19 06:02 EDT, Charalampos Stratakis
no flags Details | Diff

  None (edit)
Description William Moreno 2015-11-25 17:20:13 EST
This package does not provide "python2-<module>".

As per Python packaging guidelines [0], when there are two versions of
module "foo", the two packages must provide:
"python3-foo" for Python 3
"python2-foo" for Python 2
"python-foo" for the system default Python (currently 2, but this might
change in the future)

Please use the %python_provide macro [1] to specify the correct provides.

It's fine to do this in Rawhide only.


If anything is unclear, or if you need any kind of assistance with this
issue, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1]
https://fedoraproject.org/wiki/Packaging:Python#The_.25python_provide_macro
Comment 1 Jan Kurik 2016-02-24 09:01:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Charalampos Stratakis 2016-06-08 08:09:32 EDT
Tests are failing due to python-stuf import error, so unless disabled, package can't be re/build.
Comment 3 Ralph Bean 2016-06-28 13:37:25 EDT
Buildroot overrides for python-stuf are available:
https://bodhi.fedoraproject.org/overrides/?packages=python-stuf

So this should be buildable again.
Comment 4 Charalampos Stratakis 2016-07-19 06:02 EDT
Created attachment 1181541 [details]
provide python2-feedcache and modernize SPEC

Scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=14943325

output of 'rpm -qp --provides python-feedcache-1.4.1-5.fc25.noarch.rpm' :

python-feedcache = 1.4.1-5.fc25
python2-feedcache = 1.4.1-5.fc25
python2.7dist(feedcache) = 1.4.1

Tested in mock as well and works as expected
Comment 6 Fedora Update System 2016-11-23 12:49:28 EST
python-feedcache-1.4.1-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-88dd60ade2
Comment 7 Fedora Update System 2016-11-25 04:42:25 EST
python-feedcache-1.4.1-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-88dd60ade2
Comment 8 Fedora Update System 2016-12-05 16:41:31 EST
python-feedcache-1.4.1-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.