Bug 1285663 - tiering: Seeing error messages E "/usr/lib64/glusterfs/3.7.5/xlator/features/changetimerecorder.so(ctr_lookup+0x54f) [0x7f6c435c116f] ) 0-ctr: invalid argument: loc->name [Invalid argument] after attach tier
Summary: tiering: Seeing error messages E "/usr/lib64/glusterfs/3.7.5/xlator/features...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Joseph Elwin Fernandes
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1284834
Blocks: 1290295
TreeView+ depends on / blocked
 
Reported: 2015-11-26 08:22 UTC by Joseph Elwin Fernandes
Modified: 2016-06-20 00:02 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1284834
: 1290295 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:47:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2015-11-26 09:05:14 UTC
REVIEW: http://review.gluster.org/12760 (tier/ctr: Check filename in ctr_lookup for nameless lookup) posted (#1) for review on master by Joseph Fernandes

Comment 2 Vijay Bellur 2015-12-09 15:10:49 UTC
REVIEW: http://review.gluster.org/12760 (tier/ctr: Check filename in ctr_lookup for nameless lookup) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)

Comment 3 Vijay Bellur 2015-12-10 02:02:14 UTC
REVIEW: http://review.gluster.org/12760 (tier/ctr: Check filename in ctr_lookup for nameless lookup) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)

Comment 4 Vijay Bellur 2015-12-10 05:23:41 UTC
COMMIT: http://review.gluster.org/12760 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit db3ff1e75f6d6cf80967708778f36ae07ddb220a
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Thu Nov 26 14:33:14 2015 +0530

    tier/ctr: Check filename in ctr_lookup for nameless lookup
    
    Check filename in ctr_lookup for nameless lookup
    
    Change-Id: I1ab3f658e3b9fee708f6986d1990f16db920d2fb
    BUG: 1285663
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/12760
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>

Comment 5 Niels de Vos 2016-06-16 13:47:06 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.