Bug 1290295 - tiering: Seeing error messages E "/usr/lib64/glusterfs/3.7.5/xlator/features/changetimerecorder.so(ctr_lookup+0x54f) [0x7f6c435c116f] ) 0-ctr: invalid argument: loc->name [Invalid argument] after attach tier
tiering: Seeing error messages E "/usr/lib64/glusterfs/3.7.5/xlator/features...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Joseph Elwin Fernandes
bugs@gluster.org
: Triaged
Depends On: 1284834 1285663
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 01:01 EST by Joseph Elwin Fernandes
Modified: 2016-06-19 20:00 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285663
Environment:
Last Closed: 2016-04-19 03:50:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-10 01:02:11 EST
REVIEW: http://review.gluster.org/12935 (tier/ctr: Check filename in ctr_lookup for nameless lookup) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-11 07:27:48 EST
COMMIT: http://review.gluster.org/12935 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 3de606533048a4aa42545eef19dfefc23315c67f
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Thu Nov 26 14:33:14 2015 +0530

    tier/ctr: Check filename in ctr_lookup for nameless lookup
    
    Check filename in ctr_lookup for nameless lookup
    
    Backport of http://review.gluster.org/12760
    
    > Change-Id: I1ab3f658e3b9fee708f6986d1990f16db920d2fb
    > BUG: 1285663
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/12760
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: I2dccf8fe556c42623dc0aa89459dd2aa2a038380
    BUG: 1290295
    Reviewed-on: http://review.gluster.org/12935
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:50:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.