Bug 1285832 - Containers: 'Unexpected error encountered' when selecting relationship in containers
Containers: 'Unexpected error encountered' when selecting relationship in con...
Status: CLOSED DUPLICATE of bug 1286247
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
unspecified Severity high
: GA
: 5.5.0
Assigned To: Daniel Korn
Dave Johnson
container
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 10:39 EST by Dafna Ron
Modified: 2015-12-02 04:33 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 04:33:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs from 27 (3.23 MB, application/x-gzip)
2015-11-30 06:29 EST, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2015-11-26 10:39:54 EST
Description of problem:

occurs when clicking Relationship under containers

Version-Release number of selected component (if applicable):

cfme-5.5.0.12-rc2.1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Navigate to containers -> containers
2. click Relationships 
3.

Actual results:

Unexpected error encountered

Expected results:

We should see relationship 

Additional info:


Unexpected error encountered

Errors in Management Engine can be caused by:

① Accessing Management Engine from multiple tabs or windows of the same browser on a single machine. Close any duplicate browser sessions, then select a menu option above.
② Pressing the back button during a session.
      Close any duplicate browser sessions, then select a menu option above.
③ An internal system error.
      Please contact your administrator for assistance.


Error text:

No Class found for explorer tree node id '1-' [container/accordion_select]
Comment 1 Federico Simoncelli 2015-11-30 06:07:11 EST
Dafna can you attach the logs? Thanks.
Comment 2 Dafna Ron 2015-11-30 06:29 EST
Created attachment 1100483 [details]
logs from 27

It's no longer reproduced since my vm rebooted. 
I'll attach the log from that day though - perhaps it will show something.
Comment 3 Federico Simoncelli 2015-11-30 07:29:36 EST
You attached just evm.log (backend) but the issue is in the UI (production.log).
Comment 4 Federico Simoncelli 2015-11-30 12:01:17 EST
Daniel, could it be that this was related to bug #1286247 ?

The error seems rather similar:

No Class found for explorer tree node id '1-' [container/accordion_select]

and:

No Class found for explorer tree node id '12-' [container/explorer]

If so please discuss it with Dafna and let's close as duplicate.
Comment 5 Daniel Korn 2015-12-01 03:37:17 EST
(In reply to Federico Simoncelli from comment #4)
> Daniel, could it be that this was related to bug #1286247 ?
> 
> The error seems rather similar:

Dafna, is it possible that the scenario in which you received this error included displaying a container's Timelines/Utilization (between 1. and 2.)?
If so, it is a duplicate and I submitted a fix here:  https://github.com/ManageIQ/manageiq/pull/5647

If not, I'll need production.log/development.log or a way to reproduce.
Comment 6 Dafna Ron 2015-12-01 05:40:50 EST
oh, very possible... I was messing around with that as well so very, very possible.
Comment 7 Federico Simoncelli 2015-12-02 04:33:07 EST

*** This bug has been marked as a duplicate of bug 1286247 ***

Note You need to log in before you can comment on or make changes to this bug.