Bug 1286247 - containers: No Class found for explorer tree node id '12-' [container/explorer]
Summary: containers: No Class found for explorer tree node id '12-' [container/explorer]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: GA
: 5.6.0
Assignee: Daniel Korn
QA Contact: Dafna Ron
URL:
Whiteboard: container
: 1285832 (view as bug list)
Depends On:
Blocks: 1287858
TreeView+ depends on / blocked
 
Reported: 2015-11-27 15:21 UTC by Dafna Ron
Modified: 2016-06-29 15:12 UTC (History)
12 users (show)

Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1287858 (view as bug list)
Environment:
Last Closed: 2016-06-29 15:12:52 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
log (935.07 KB, application/x-gzip)
2015-11-27 15:21 UTC, Dafna Ron
no flags Details
production log (96.18 KB, application/x-gzip)
2015-11-30 11:39 UTC, Dafna Ron
no flags Details
logs (827.12 KB, application/x-gzip)
2015-11-30 14:00 UTC, Dafna Ron
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Dafna Ron 2015-11-27 15:21:57 UTC
Created attachment 1099732 [details]
log

Description of problem:

selecting timeline for containers -> timeline pods -> containers causes:
No Class found for explorer tree node id '12-' [container/explorer] 

Version-Release number of selected component (if applicable):

cfme-5.5.0.12-rc2.1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. select containers -> containers -> first container 
2. select monitoring -> timelines
3. select containers -> pods 
4. select monitoring -> timelines
5. select containers -> containers

Actual results:

1. we get an exception: No Class found for explorer tree node id '12-' [container/explorer] 
2. we have to logout -> login to be able to view containers again

Expected results:

We should not get an exception.
we should not have to logout ->login to view containers again. 

Additional info:


Unexpected error encountered

Errors in Management Engine can be caused by:

① Accessing Management Engine from multiple tabs or windows of the same browser on a single machine. Close any duplicate browser sessions, then select a menu option above.
② Pressing the back button during a session.
      Close any duplicate browser sessions, then select a menu option above.
③ An internal system error.
      Please contact your administrator for assistance.


Error text:

No Class found for explorer tree node id '12-' [container/explorer]

Comment 1 Federico Simoncelli 2015-11-30 11:12:42 UTC
This is a UI bug but the logs attached are the backend ones. Dafna please attach the production.log as well (you should see the stacktrace there).

Comment 2 Dafna Ron 2015-11-30 11:39:45 UTC
Created attachment 1100484 [details]
production log

Comment 3 Daniel Korn 2015-11-30 12:01:08 UTC
There should be another step: "select a random pod" between 3 and 4, right Dafna (I was getting the same error in that case).

Comment 4 Federico Simoncelli 2015-11-30 12:33:37 UTC
I have the feeling that this may reproduce with "Utilization" as well (not just "Timeline"). Can you test that as well? Thanks.

Comment 5 Dafna Ron 2015-11-30 12:46:57 UTC
(In reply to Daniel Korn from comment #3)
> There should be another step: "select a random pod" between 3 and 4, right
> Dafna (I was getting the same error in that case).


Yes :) I think that you have to select the pod to get to the timeline :) sorry for not writing that.

Comment 6 Dafna Ron 2015-11-30 13:55:17 UTC
(In reply to Federico Simoncelli from comment #4)
> I have the feeling that this may reproduce with "Utilization" as well (not
> just "Timeline"). Can you test that as well? Thanks.

Utilization is not working to begin with (just select it and get an error)

Will add the log for that but I think it was a bug that was already opened? 


Unexpected error encountered

Errors in Management Engine can be caused by:

① Accessing Management Engine from multiple tabs or windows of the same browser on a single machine. Close any duplicate browser sessions, then select a menu option above.
② Pressing the back button during a session.
      Close any duplicate browser sessions, then select a menu option above.
③ An internal system error.
      Please contact your administrator for assistance.


Error text:

Action not implemented [container/x_button]

Comment 7 Dafna Ron 2015-11-30 14:00:01 UTC
Created attachment 1100509 [details]
logs

Comment 8 Daniel Korn 2015-11-30 14:50:43 UTC
thanks Dafna, and it's true one needs to select a specific pod (or other entity in general). Anyway, I'm working on it.

(In reply to Dafna Ron from comment #6)
> Utilization is not working to begin with (just select it and get an error)

I fixed the utilization for containers last week: https://bugzilla.redhat.com/show_bug.cgi?id=1283683

Comment 9 Daniel Korn 2015-12-01 08:26:03 UTC
proposed fix: https://github.com/ManageIQ/manageiq/pull/5647

Comment 10 Federico Simoncelli 2015-12-02 09:33:07 UTC
*** Bug 1285832 has been marked as a duplicate of this bug. ***

Comment 14 Dafna Ron 2016-04-25 17:12:50 UTC
verified on cfme-5.6.0.4-beta2.3.1.el7cf.x86_64

Comment 15 Lucy Bopf 2016-05-17 05:12:05 UTC
It appears that this bug should no longer be documented as a known issue (and the requires_doc_text flag has been set to '-'). Removing doc text as well.

Comment 17 errata-xmlrpc 2016-06-29 15:12:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.