Bug 1285852 - sssd: [sysdb_add_user] (0x0400): Error: 17 (File exists)
sssd: [sysdb_add_user] (0x0400): Error: 17 (File exists)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.8
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: SSSD Maintainers
Namita Soman
: ZStream
Depends On: 1283592
Blocks: 1284814 1290456
  Show dependency treegraph
 
Reported: 2015-11-26 11:41 EST by Jakub Hrozek
Modified: 2016-05-10 16:25 EDT (History)
16 users (show)

See Also:
Fixed In Version: sssd-1.13.2-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283592
: 1290456 (view as bug list)
Environment:
Last Closed: 2016-05-10 16:25:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sssd logs (40.81 KB, text/plain)
2016-03-02 03:43 EST, Sudhir Menon
no flags Details

  None (edit)
Comment 7 Sudhir Menon 2016-03-02 03:42:50 EST
Verified the bug using  

RHEL6.8 client
ipa-client-3.0.0-50.el6.x86_64
sssd-ipa-1.13.3-15.el6.x86_64

RHEL7.2 IPA Server
ipa-server-4.2.0-15.el7_2.3.x86_64
sssd-1.13.0-40.el7_2.1.x86_64

Observations:-
1. when you run 'id username' command on the IPA server first and then run it on IPA client, the 'id username' command displays output on the ipaclient.
2. 'no such user' is displayed if the 'id username' command is run on the ipaclient first. Is this expected ? 

Attaching the logs for reference which shows 'Error 17' when the id command is run on client.
Comment 8 Sudhir Menon 2016-03-02 03:43 EST
Created attachment 1132172 [details]
sssd logs
Comment 10 Sudhir Menon 2016-03-03 05:51:33 EST
Observations:-

After running the below command on IPA-Server and IPA-client, the issue mentioned in comment #7 is not seen. Also Error 17 is not seen in the logs.

#service sssd stop; rm -rf /var/lib/sss/{db,mc}/*; service sssd start

RHEL6.8 client
ipa-client-3.0.0-50.el6.x86_64
sssd-ipa-1.13.3-15.el6.x86_64

RHEL7.2 IPA Server
ipa-server-4.2.0-15.el7_2.3.x86_64
sssd-1.13.0-40.el7_2.1.x86_64
Comment 12 errata-xmlrpc 2016-05-10 16:25:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0782.html

Note You need to log in before you can comment on or make changes to this bug.