Bug 1285860 - [abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\xed' in position 14: ordinal not in range(128)
[abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode c...
Status: CLOSED DUPLICATE of bug 1279204
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4c5a63b8d1d8ab43e3fb6085032...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 12:30 EST by Bruno Gambarini
Modified: 2015-11-30 07:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 07:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (1.12 MB, text/plain)
2015-11-26 12:31 EST, Bruno Gambarini
no flags Details
File: _var_tmp_dnf-bruno-3_votohk_dnf.librepo.log (217.74 KB, text/plain)
2015-11-26 12:31 EST, Bruno Gambarini
no flags Details
File: _var_tmp_dnf-bruno-3_votohk_dnf.log (18.95 KB, text/plain)
2015-11-26 12:31 EST, Bruno Gambarini
no flags Details
File: _var_tmp_dnf-bruno-3_votohk_dnf.rpm.log (343 bytes, text/plain)
2015-11-26 12:31 EST, Bruno Gambarini
no flags Details
File: _var_tmp_dnf-bruno-3_votohk_hawkey.log (17.31 KB, text/plain)
2015-11-26 12:31 EST, Bruno Gambarini
no flags Details
File: backtrace (1.35 KB, text/plain)
2015-11-26 12:31 EST, Bruno Gambarini
no flags Details
File: dnf-makecache.log (13.38 KB, text/plain)
2015-11-26 12:31 EST, Bruno Gambarini
no flags Details
File: environ (1.69 KB, text/plain)
2015-11-26 12:31 EST, Bruno Gambarini
no flags Details

  None (edit)
Description Bruno Gambarini 2015-11-26 12:30:52 EST
Version-Release number of selected component:
dnf-1.1.4-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 -OO /bin/dnf list all
executable:     /bin/dnf
kernel:         4.2.6-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\xed' in position 14: ordinal not in range(128)

Traceback (most recent call last):
  File "/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/__init__.py", line 271, in run
    return self.base.output_packages('list', pkgnarrow, patterns)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 435, in output_packages
    '=' : clar, 'not in' : clai})
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 589, in listPkgs
    print('%s' % description)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 44, in write
    self.stream.write(s)
UnicodeEncodeError: 'ascii' codec can't encode character '\xed' in position 14: ordinal not in range(128)

Local variables in innermost frame:
self: <dnf.i18n.UnicodeStream object at 0x7f475930d9e8>
s: 'Pacotes disponíveis'
Comment 1 Bruno Gambarini 2015-11-26 12:31:23 EST
Created attachment 1099338 [details]
File: _var_log_dnf.log
Comment 2 Bruno Gambarini 2015-11-26 12:31:30 EST
Created attachment 1099339 [details]
File: _var_tmp_dnf-bruno-3_votohk_dnf.librepo.log
Comment 3 Bruno Gambarini 2015-11-26 12:31:33 EST
Created attachment 1099340 [details]
File: _var_tmp_dnf-bruno-3_votohk_dnf.log
Comment 4 Bruno Gambarini 2015-11-26 12:31:35 EST
Created attachment 1099341 [details]
File: _var_tmp_dnf-bruno-3_votohk_dnf.rpm.log
Comment 5 Bruno Gambarini 2015-11-26 12:31:37 EST
Created attachment 1099342 [details]
File: _var_tmp_dnf-bruno-3_votohk_hawkey.log
Comment 6 Bruno Gambarini 2015-11-26 12:31:39 EST
Created attachment 1099343 [details]
File: backtrace
Comment 7 Bruno Gambarini 2015-11-26 12:31:42 EST
Created attachment 1099344 [details]
File: dnf-makecache.log
Comment 8 Bruno Gambarini 2015-11-26 12:31:44 EST
Created attachment 1099345 [details]
File: environ
Comment 9 Michal Luscon 2015-11-30 07:48:29 EST

*** This bug has been marked as a duplicate of bug 1279204 ***

Note You need to log in before you can comment on or make changes to this bug.