Bug 1279204 - [abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\u2014' in position 507: ordinal not in range(128)
[abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode c...
Status: CLOSED DUPLICATE of bug 1332012
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:12add807492894db891e6c4e081...
:
: 1285860 1317245 1320413 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 10:30 EST by aten
Modified: 2016-05-09 07:31 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-09 07:31:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (5.50 MB, text/plain)
2015-11-08 10:30 EST, aten
no flags Details
File: _var_tmp_dnf-korneta-gnmxn1_dnf.rpm.log (98.77 KB, text/plain)
2015-11-08 10:30 EST, aten
no flags Details
File: backtrace (1.93 KB, text/plain)
2015-11-08 10:31 EST, aten
no flags Details
File: dnf-makecache.log (2.83 MB, text/plain)
2015-11-08 10:31 EST, aten
no flags Details
File: environ (2.18 KB, text/plain)
2015-11-08 10:31 EST, aten
no flags Details
File: _var_tmp_dnf-korneta-gnmxn1_dnf.log (11.97 MB, text/plain)
2015-11-08 10:31 EST, aten
no flags Details
File: _var_tmp_dnf-korneta-gnmxn1_hawkey.log (18.24 MB, text/plain)
2015-11-08 10:33 EST, aten
no flags Details

  None (edit)
Description aten 2015-11-08 10:30:27 EST
Version-Release number of selected component:
dnf-1.1.3-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 -OO /usr/bin/dnf repoquery -i adobe-source-han-sans-tw-fonts
executable:     /usr/bin/dnf
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            1001

Truncated backtrace:
i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\u2014' in position 507: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 136, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/repoquery.py", line 399, in run
    print(pkg)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 44, in write
    self.stream.write(s)
UnicodeEncodeError: 'ascii' codec can't encode character '\u2014' in position 507: ordinal not in range(128)

Local variables in innermost frame:
s: 'Name        : adobe-source-han-sans-tw-fonts\nVersion     : 1.004\nRelease     : 1.fc23\nArchitecture: noarch\nSize        : 30264728\nLicense     : OFL\nSource RPM  : adobe-source-han-sans-tw-fonts-1.004-1.fc23.src.rpm\nBuild Date  : 2015-08-07 03:34\nPackager    : Fedora Project\nURL         : https://github.com/adobe-fonts/source-han-sans/\nSummary     : Adobe OpenType Pan-CJK font family for Traditional Chinese\nDescription :\nSource Han Sans is a sans serif Pan-CJK font family\nthat is offered in seven weights—ExtraLight, Light,\nNormal, Regular, Medium, Bold, and Heavy—and\nin several OpenType/CFF-based deployment configurations\nto accommodate various system requirements or limitations.\n\nAs the name suggests, Pan-CJK fonts are intended to\nsupport the characters necessary to render or\ndisplay text in Simplified Chinese, Traditional Chinese,\nJapanese, and Korean.\n'
self: <dnf.i18n.UnicodeStream object at 0x7fbc8410ab38>
Comment 1 aten 2015-11-08 10:30:56 EST
Created attachment 1091293 [details]
File: _var_log_dnf.log
Comment 2 aten 2015-11-08 10:30:59 EST
Created attachment 1091294 [details]
File: _var_tmp_dnf-korneta-gnmxn1_dnf.rpm.log
Comment 3 aten 2015-11-08 10:31:01 EST
Created attachment 1091295 [details]
File: backtrace
Comment 4 aten 2015-11-08 10:31:13 EST
Created attachment 1091296 [details]
File: dnf-makecache.log
Comment 5 aten 2015-11-08 10:31:14 EST
Created attachment 1091297 [details]
File: environ
Comment 6 aten 2015-11-08 10:31:59 EST
Created attachment 1091298 [details]
File: _var_tmp_dnf-korneta-gnmxn1_dnf.log
Comment 7 aten 2015-11-08 10:33:12 EST
Created attachment 1091299 [details]
File: _var_tmp_dnf-korneta-gnmxn1_hawkey.log
Comment 8 Jaroslav Mracek 2015-11-18 07:28:41 EST
Please, what lang do you have? (echo $LANG)
Comment 9 aten 2015-11-18 11:48:43 EST
$ echo $LANG
en_US.utf8
Comment 10 Michal Luscon 2015-11-30 07:48:29 EST
*** Bug 1285860 has been marked as a duplicate of this bug. ***
Comment 11 allan.herrera777 2015-12-05 16:29:52 EST
Another user experienced a similar problem:

During the Fedy MS Fonts installer.

reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 -OO /usr/bin/dnf repoquery -i adobe-source-han-sans-tw-fonts
event_log:      2015-12-05-14:25:47> ('report_uReport' completed successfully)
executable:     /usr/bin/dnf
kernel:         4.2.6-301.fc23.x86_64
package:        dnf-1.1.4-2.fc23
reason:         i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\u2014' in position 507: ordinal not in range(128)
runlevel:       N 5
type:           Python3
uid:            1000
Comment 12 Jaroslav Mracek 2016-04-11 07:53:28 EDT
*** Bug 1320413 has been marked as a duplicate of this bug. ***
Comment 13 Jaroslav Mracek 2016-04-11 07:54:24 EDT
*** Bug 1317245 has been marked as a duplicate of this bug. ***
Comment 14 Honza Silhan 2016-05-09 07:31:03 EDT

*** This bug has been marked as a duplicate of bug 1332012 ***

Note You need to log in before you can comment on or make changes to this bug.