Bug 1285881 - Wrong OVS flows created for new networks
Wrong OVS flows created for new networks
Status: CLOSED DUPLICATE of bug 1289994
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ---
: 8.0 (Liberty)
Assigned To: lpeer
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 15:37 EST by Brent Eagles
Modified: 2016-04-26 10:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 21:57:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1507776 None None None Never
OpenStack gerrit 237878 None None None Never

  None (edit)
Description Brent Eagles 2015-11-26 15:37:50 EST
Cloned from launchpad bug 1507776.

Description:

neutron-openvswitch-agent seems to create wrong OVS flows for newly created networks. This causes package losses, including lost DHCP requests, resulting in instances that did not receive an IP. This can cause tempest tests to fail.

Restarting the neutron-openvswitch-agent will result in properly created OVS flows, and the traffic flowing properly.

The issue has been observed using VLAN as a network_type and no other special configurations (like DVR being enabled), while running tempest tests: tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.
For example, testr run tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_network_basic_ops randomly fails due to the fact that the instance did not get any reply for its DHCP request. NOTE: while the OVS flows are wrong for each run of the test, the test still has a small chance of success.

Hypervisor used: Hyper-V. The port on Hyper-V are properly bound and the VLAN tag properly set, the ports are marked as "alive". The network traffic arrives with the proper VLAN tag at the Networking Controller. The bug is unrelated to neutron-hyperv-agent and Hyper-V.

This issue has been observed in the Liberty release.

Details: http://paste.openstack.org/show/476764/

IRC discussion: http://eavesdrop.openstack.org/irclogs/%23openstack-neutron/%23openstack-neutron.2015-10-19.log.html#t2015-10-19T20:27:31

Specification URL (additional information):

https://bugs.launchpad.net/neutron/+bug/1507776
Comment 1 Assaf Muller 2015-12-16 21:57:45 EST
Will be resolved via OSP 8 rebase before GA.

*** This bug has been marked as a duplicate of bug 1289994 ***

Note You need to log in before you can comment on or make changes to this bug.