Bug 1289994 - Request for rebase on upstream stable/liberty (7.0.1) before release.
Request for rebase on upstream stable/liberty (7.0.1) before release.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: ga
: 8.0 (Liberty)
Assigned To: Miguel Angel Ajo
Itzik Brown
: Rebase
: 1275322 1285879 1285881 1285882 1286256 (view as bug list)
Depends On:
Blocks: 1275322
  Show dependency treegraph
 
Reported: 2015-12-09 08:26 EST by Miguel Angel Ajo
Modified: 2016-04-26 11:40 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-neutron-7.0.1-1.el7ost
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:17:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
majopela: needinfo+
majopela: needinfo+


Attachments (Terms of Use)
tempest neutron api tests' results (239.28 KB, text/html)
2016-01-26 04:48 EST, Itzik Brown
no flags Details
tempest neutron network scenario tests' results (25.20 KB, text/html)
2016-01-26 04:50 EST, Itzik Brown
no flags Details

  None (edit)
Description Miguel Angel Ajo 2015-12-09 08:26:23 EST
Description of problem:

Upstream stabe/liberty has already identified and fixed a considerable
amount of bugs which are of our interest.

Rebasing on top of those changes would be in our best interest:

	50373f	Fix default RBAC policy quota		
	927353	Skip bindings with agent_id=None		
	ccebcd	Correct unwatch_log to support python <= 2.7.5		
	5a87dd	Add the missing arg of RetryRequest exception in _lock_subnetpool		
	5469d7	Fix get_subnet_ids_on_router in dvr scheduler		
	b77a41	Avoid race condition for reserved DHCP ports		
	53816c	force releasenotes warnings to be treated as errors		
	478012	Delete HA network when last HA router is deleted		
	8c0927	Add UnionModel support to filter query generator		
	c78ad0	Don't drop ARP table jump during OVS rewiring		
	9650a8	Fix incomprehensible releasenotes		
	410418	tox: pass TEMPEST_CONFIG_DIR envvar into api target environment		
	032f4c	Updated from global requirements		
	b28011	IPAM: fix 'enable-dhcp' with internal driver		
	271413	Fix use of fields argument in get_rbac_policies		
	d6a628	Allow to specify branch for creating new migration		
	2a27d7	Datapath on L2pop only for agents with tunneling-ip		
	588e9e	Don't add default route to HA router if there is no gateway ip		
	325257	Fix dvr_local_router.floating_ip_added_dist failure after agent restart		
	bbbd0b	Add transaction for setting agent_id in L3HARouterAgentPortBinding		
	7c4bf2	Updated from global requirements		
	964538	Fix releasenotes/../unreleased.rst		
	7d1db3	Cleanup dhcp namespace upon dhcp setup.		
	040342	Adding a function prefix before parenthesis		
	e3af26	Validate ethertype for icmp protocols		
	582582	sriov: add extensions option to configuration file		
	074ccb	Remove TEMPEST_CONFIG_DIR in the api tox env		
	051af0	Add "unreleased" release notes page		
	54c848	Add reno for release notes management		
	943b15	More graceful ovs-agent restart		
	de1358	Don't remove ip addresses if not master		
	2e098c	Add call to pluggable IPAM from ml2 delete_subnet		
	0e8ca8	configure_for_func_testing.sh: Fix arguments for get_packages		
	bc31e4	Add Liberty release notes as reno yaml files		
	528957	Optimize delete_csnat_router_interface_ports db query		
	8c30cb	Fix iptables modules references in rule generation		
	5cc55c	Fix incorrect passing port dict in pluggable IPAM		
	e49b65	Add first reno-based release note		
	c5629d	Change function call order in ovs_neutron_agent.		
	f6e950	Log end of router updates for PD and delete branches		
	af90ec	Optimize get_bridge_for_tap_device		
	1367d6	Use string formatting instead of string replace		
	0f5bf2	Fix usage of mutable object as default value		
	445f5a	test_db_base_plugin_v2: Skip a few tests on some platforms		
	aa893c	Added postcommit hooks in ovsvapp mech_driver		
	cad088	Don't update metadata_proxy if metadata is not enabled		
	0007ec	Better tolerate deleted OVS ports in OVS agent		
	a4a966	Imported Translations from Zanata		
	fd4294	Remove excessive fallback iptables ACCEPT rules		
	cee26f	Updated from global requirements		
	47f7e7	Move retries out of ML2 plugin		
	4a2a93	Fix DVR downgrade exception / error code		
	765c74	Set security group provider rule for icmpv6 RA in DVR		
	24d0b0	Fix _restore_local_vlan_map race		
	e7978d	ovs_neutron_agent: display loaded extensions		
	4b23b6	Deepcopy port dict in dhcp rpc handler		
	b66169	Fix l2pop regression		
	4428b2	Set ip_nonlocal_bind in namespace if it exists		
	9d40fe	Remove SUPPORTED_AGENT_TYPES for l2pop		
	5d7c34	Fix AttributeError on port_bound for missing ports		
	82c074	Updated from global requirements		
	0b5285	The exception type is wrong and makes the except block not work		
	aebd76	Imported Translations from Zanata		
	ea9c9c	Add -constraints sections for base CI jobs		
	799a3c	Updated from global requirements		
	b09a97	Kill conntrackd state on HA routers FIP disassociation		
	a43e35	Handle empty bridge case in OVSBridge.get_ports_attributes		
	ca883f	Fix the bug of "Spelling error of a word"		
	b7f8da	QoS SR-IOV: allow to reset vf rate when VF is assigend to VM		
	1666d5	Fix rule generation for single and all host rules		
	c80e14	Correct MAC representation to match iptables output		
	bdb006	Fix inconsistency in DHCPv6 hosts and options generation		
	4a23eb	Always send status update for processed floating ips		
	c518d6	L3 agent: use run_immediately parameter to sync after start		
	9a061c	Change router unbinding logic to be consistent with data model		
	073845	Fix iptables comments for bare jump rules	
        * <--- we are here
Comment 3 Assaf Muller 2015-12-16 18:29:37 EST
*** Bug 1285882 has been marked as a duplicate of this bug. ***
Comment 4 Assaf Muller 2015-12-16 21:57:45 EST
*** Bug 1285881 has been marked as a duplicate of this bug. ***
Comment 5 Assaf Muller 2015-12-16 21:58:39 EST
*** Bug 1285879 has been marked as a duplicate of this bug. ***
Comment 6 Assaf Muller 2015-12-16 21:59:40 EST
*** Bug 1286256 has been marked as a duplicate of this bug. ***
Comment 8 Assaf Muller 2015-12-17 23:45:56 EST
*** Bug 1275322 has been marked as a duplicate of this bug. ***
Comment 12 Itzik Brown 2016-01-26 04:48 EST
Created attachment 1118407 [details]
tempest neutron api tests' results
Comment 13 Itzik Brown 2016-01-26 04:50 EST
Created attachment 1118408 [details]
tempest neutron network scenario tests' results
Comment 14 Itzik Brown 2016-01-26 04:56:49 EST
Checked network api and scenario tests (attached results)
tempest.scenario.test_security_groups_basic_ops passed (without cross hosts).

Version
=======
openstack-neutron-common-7.0.0-5.el7ost.noarch
python-neutron-lbaas-7.0.0-2.el7ost.noarch
python-neutronclient-3.1.0-1.el7ost.noarch
openstack-neutron-lbaas-7.0.0-2.el7ost.noarch
openstack-neutron-openvswitch-7.0.0-5.el7ost.noarch
openstack-neutron-metering-agent-7.0.0-5.el7ost.noarch
python-neutron-7.0.0-5.el7ost.noarch
openstack-neutron-7.0.0-5.el7ost.noarch
openstack-neutron-ml2-7.0.0-5.el7ost.noarch
Comment 15 Miguel Angel Ajo 2016-02-25 04:07:31 EST
I believe there's no doctext required for this bz.
Comment 16 errata-xmlrpc 2016-04-07 17:17:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.