Bug 1285899 - Metric rollups for container providers are not properly determined
Metric rollups for container providers are not properly determined
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: C&U Capacity and Utilization (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Federico Simoncelli
Einat Pacifici
container
:
Depends On: 1321561
Blocks: 1287766
  Show dependency treegraph
 
Reported: 2015-11-26 17:47 EST by Federico Simoncelli
Modified: 2016-06-29 11:12 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1287766 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:12:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Federico Simoncelli 2015-11-26 17:47:00 EST
Description of problem:
Metric rollups of container nodes to the container provider are not properly determined:

- memory usage is not computed
- cores usage is computed using a simple average (instead of a weighted average on number of cores)

How reproducible:
100%

Steps to Reproduce:
1. add a container provider with metrics support

Actual results:
Daily/hourly metrics rollups for containers providers are not properly determined (see above)

Expected results:
Daily/hourly metrics rollups for containers providers should be properly computed.

Additional info:
These data are not yet visibile in the UI but since are stored in the database we need to get the computation right so that once the UI is added the values are correct.
Comment 1 Federico Simoncelli 2015-11-26 17:49:42 EST
https://github.com/ManageIQ/manageiq/pull/5587
Comment 2 Oleg Barenboim 2015-11-28 13:26:49 EST
https://github.com/ManageIQ/manageiq/pull/5587 has been merged
Comment 9 errata-xmlrpc 2016-06-29 11:12:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.