Bug 128603 - Trouble exporting binary RPMs
Trouble exporting binary RPMs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Developer Suite
Classification: Retired
Component: RPM Plug-in (Show other bugs)
2.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Rick Moseley
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-26 19:21 EDT by Aaron Luchko
Modified: 2007-04-18 13:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 17:01:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Luchko 2004-07-26 19:21:45 EDT
Description of problem: Unable to export the at or helloworld rpms do
to errors, using both ibm and bea jvms on x86
"
Export RPM Errors
  Error waiting for /var/tmp/aluchko/rpm_workarea/rpmshell.sh to complete.
"
and
"
"

Version-Release number of selected component (if applicable):
eclipse-rpm-1.1.0-3

How reproducible:
always

Steps to Reproduce:
1. Follow eclipse RPM test plan making and importing the at and pump
projects (can import others if you want as well).
2. Try to export a binary RPM of either at or helloworld (doesn't
matter if you have source selected as well).
  
Actual results:
You'll get the aforementioned error message 
"
Export RPM Errors
  Error waiting for /var/tmp/aluchko/rpm_workarea/rpmshell.sh to complete.
"

Expected results:
It exports a binary RPM

Additional info:
I also encountered an error where trying to export a source RPM with
at would give the error,
"
!RPMCore.Error_trying_to_extract_the_source_tarball_using_this_command_--__652!cd
/var/tmp/aluchko/rpm_workarea/SOURCES/
/bin/tar -xjf helloworld-2.tar.bz2
"
though I couldn't recreate this second one.  I also tried the slocate
and pump rpms and neither was affected, as a side note there was an
earlier where special characters in the spec files would cause
problems with certain rpms however the rpms affected by this were at
and pump but pump was unaffected by this bug and helloworld was
unaffected by the former and 'at' was affected by both and slocate was
affected by neither, this covering of all the different permutations
would suggest no relationship exists between the bugs.
Comment 1 Rick Moseley 2004-07-28 17:01:29 EDT
The "helloworld" problem was created by the SpecOps:createSpecFile
method and it had a bug where names were hard-coded.  This method has
been fixed to take those out and improve some functionality by using
some newer macros associated with rpm.

The "at" problem is caused by the source RPM itself.  The source RPM
for at cannot be installed and built manually using the "rpm
-i"/"rpmbuild -ba" commands, so the RPM plugin will error out as
described above.

Note You need to log in before you can comment on or make changes to this bug.