Bug 1286062 - Dashboard edit & menu widget edit screens are lacking close buttons
Dashboard edit & menu widget edit screens are lacking close buttons
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.6.0
Assigned To: Milan Zazrivec
Jiri Stefanisin
:
Depends On:
Blocks: 1288187
  Show dependency treegraph
 
Reported: 2015-11-27 05:29 EST by Milan Zazrivec
Modified: 2016-06-29 11:12 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1288187 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:12:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dashboard edit (114.05 KB, image/jpeg)
2015-11-27 05:29 EST, Milan Zazrivec
no flags Details
menu widget edit (112.69 KB, image/jpeg)
2015-11-27 05:33 EST, Milan Zazrivec
no flags Details

  None (edit)
Description Milan Zazrivec 2015-11-27 05:29:13 EST
Created attachment 1099633 [details]
Dashboard edit

Description of problem:
Dashboard edit & menu widget edit screens are lacking close buttons
which would allow deletion of particular widgets from a dashboard
or shortcuts from menu widgets.

Version-Release number of selected component (if applicable):
CFME 5.5

How reproducible:
Always

Steps to Reproduce:
1. Cloud Intelligence -> Reports -> Dashboards -> Edit a dashboard
2. Cloud Intelligence -> Reports -> Dashboard Widgets -> Menus -> Edit a menu widget

Actual results:
Dashboard widgets & menu shortcuts are lacking close buttons.

Expected results:
The close button, a nice cross like 'x', allowing deletion, is rendered.

Additional info:
N/A
Comment 1 Milan Zazrivec 2015-11-27 05:33 EST
Created attachment 1099634 [details]
menu widget edit
Comment 3 CFME Bot 2015-12-14 12:21:41 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/06ca257e43f3243508f57dc59da946f7c6543bbe

commit 06ca257e43f3243508f57dc59da946f7c6543bbe
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Thu Nov 26 17:17:53 2015 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Fri Dec 4 11:55:33 2015 +0100

    Dashboard & menu widget editing are lacking close buttons
    
    This is removal of forgotten delbox styling (replacement
     with patternfly styling).
    
    Leftover after 0ae3cf18769393ed851119543d021c455cad45c8
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1286062

 app/views/report/_widget_form_menu.html.haml          |  2 +-
 spec/views/report/_db_widget_remove.html.haml_spec.rb | 16 ++++++++++++++++
 spec/views/report/_widget_form_menu.html.haml_spec.rb | 14 ++++++++++++++
 3 files changed, 31 insertions(+), 1 deletion(-)
 create mode 100644 spec/views/report/_db_widget_remove.html.haml_spec.rb
 create mode 100644 spec/views/report/_widget_form_menu.html.haml_spec.rb
Comment 6 errata-xmlrpc 2016-06-29 11:12:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.