Bug 1288187 - Dashboard edit & menu widget edit screens are lacking close buttons
Dashboard edit & menu widget edit screens are lacking close buttons
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.2
Assigned To: Milan Zázrivec
Nandini Chandra
: ZStream
Depends On: 1286062
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 14:04 EST by John Prause
Modified: 2016-02-10 10:21 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286062
Environment:
Last Closed: 2016-02-10 10:21:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Prause 2015-12-03 14:04:18 EST
+++ This bug was initially created as a clone of Bug #1286062 +++

Description of problem:
Dashboard edit & menu widget edit screens are lacking close buttons
which would allow deletion of particular widgets from a dashboard
or shortcuts from menu widgets.

Version-Release number of selected component (if applicable):
CFME 5.5

How reproducible:
Always

Steps to Reproduce:
1. Cloud Intelligence -> Reports -> Dashboards -> Edit a dashboard
2. Cloud Intelligence -> Reports -> Dashboard Widgets -> Menus -> Edit a menu widget

Actual results:
Dashboard widgets & menu shortcuts are lacking close buttons.

Expected results:
The close button, a nice cross like 'x', allowing deletion, is rendered.

Additional info:
N/A

--- Additional comment from Milan Zazrivec on 2015-11-27 05:33 EST ---



--- Additional comment from CFME Bot on 2015-11-27 06:06:17 EST ---

https://github.com/ManageIQ/manageiq/pull/5623
Comment 2 Harpreet Kataria 2016-01-13 12:17:15 EST
Milan, 

This one needs to be cherry-picked

~ Harpreet
Comment 4 John Prause 2016-01-14 13:32:04 EST
Milan: Please wait until http://gitlab.cloudforms.lab.eng.rdu2.redhat.com/cloudforms/cfme/merge_requests/713 is merged,..then you can set this to Post.

Thanks!
Comment 5 Milan Zázrivec 2016-01-14 14:51:11 EST
Yes, the correct status should have been ON_DEV, sorry.
Comment 6 CFME Bot 2016-01-15 12:53:21 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=29ab196427a91396344e126b0009a57728d2128d

commit 29ab196427a91396344e126b0009a57728d2128d
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Thu Nov 26 17:17:53 2015 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Wed Jan 13 18:48:51 2016 +0100

    Dashboard & menu widget editing are lacking close buttons
    
    This is removal of forgotten delbox styling (replacement
     with patternfly styling).
    
    Leftover after 0ae3cf18769393ed851119543d021c455cad45c8
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288187
    (cherry picked from commit 06ca257e43f3243508f57dc59da946f7c6543bbe)

 app/views/report/_widget_form_menu.html.haml          |  2 +-
 spec/views/report/_db_widget_remove.html.haml_spec.rb | 16 ++++++++++++++++
 spec/views/report/_widget_form_menu.html.haml_spec.rb | 14 ++++++++++++++
 3 files changed, 31 insertions(+), 1 deletion(-)
 create mode 100644 spec/views/report/_db_widget_remove.html.haml_spec.rb
 create mode 100644 spec/views/report/_widget_form_menu.html.haml_spec.rb
Comment 7 CFME Bot 2016-01-15 12:53:26 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8f0e7420fa3c4335511d2d5e5d9b58d0c65241b5

commit 8f0e7420fa3c4335511d2d5e5d9b58d0c65241b5
Merge: ba9c407 29ab196
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Jan 15 12:16:38 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Jan 15 12:16:38 2016 -0500

    Merge branch 'fix_forgotten_delbox_styling' into '5.5.z'
    
    Dashboard & menu widget editing are lacking close buttons
    
    This is removal of forgotten delbox styling (replacement
     with patternfly styling).
    
    Leftover after 0ae3cf18769393ed851119543d021c455cad45c8
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288187
    (cherry picked from commit 06ca257e43f3243508f57dc59da946f7c6543bbe)
    
    See merge request !713

 app/views/report/_widget_form_menu.html.haml          |  2 +-
 spec/views/report/_db_widget_remove.html.haml_spec.rb | 16 ++++++++++++++++
 spec/views/report/_widget_form_menu.html.haml_spec.rb | 14 ++++++++++++++
 3 files changed, 31 insertions(+), 1 deletion(-)
Comment 9 Nandini Chandra 2016-01-25 12:21:50 EST
Verified in 5.5.2.
Comment 10 errata-xmlrpc 2016-02-10 10:21:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.