Bug 128611 - USB hard drive freezes system after a short while
USB hard drive freezes system after a short while
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-26 23:53 EDT by Benjamin Hayes
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Hayes 2004-07-26 23:53:00 EDT
Description of problem:
Each time that we plug a usb hard drive (actually a drive inside of a 
usb enclosure case) and copy and write files back and forth for about 
ten minutes, the entire system freezes.  No messages in any log file 
or anything to tip us off that bad things are going to happen. 

Version-Release number of selected component (if applicable):
2.4.21-4.EL

How reproducible:
Through normal file copy and writing to device.

Steps to Reproduce:
1. Plug in USB Drive into machine
2. Run some copies back and forth for about 10 minutes
3. Freeze, no network, console, keyboard, mouse, nothing
  
Actual results:
Freezes system, so that a power cycle is the only solution

Expected results:
Should not lock system up.

Additional info:
Comment 1 Benjamin Hayes 2004-07-26 23:54:44 EDT
By the way, I was reading Bug #111576, and it sounded familiar, but I 
could not find the kernels related to the bug.  They might actually 
fix the issue...
Comment 2 Benjamin Hayes 2004-07-27 10:53:43 EDT
I noticed that on the site www.linux-usb.org, that they said if you 
are running a USB 2.0 Device on a kernel older than 2.4.22, Bad 
things should happen.  Has there been a kernel release that would put 
me at or above 2.4.22 for an Itanium 64-bit?
Comment 3 Suzanne Hillman 2004-07-30 12:25:36 EDT
This looks like something for which you might be best off going
through support:

https://www.redhat.com/apps/support/
Comment 4 Pete Zaitcev 2004-08-19 20:26:39 EDT
I'll need something to break the lockup (and get a stack trace),
but since NMI watchdog doesn't work on ia64, I have no idea how
to do it. A support specialist for Itanium might know how to
extract required stack trace.
Comment 5 RHEL Product and Program Management 2007-10-19 15:22:10 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.