Bug 1286118 - Deleting stack can fail persistently due to missing user
Deleting stack can fail persistently due to missing user
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity high
: z3
: 7.0 (Kilo)
Assigned To: Zane Bitter
Amit Ugol
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 06:22 EST by Steven Hardy
Modified: 2016-04-26 12:13 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-heat-2015.1.2-3.el7ost
Doc Type: Bug Fix
Doc Text:
Heat did not ignore a "Not Found" exception when trying to fetch a stack user; that is, a Keystone user created to allow servers deployed in the stack to authenticate back to Heat. As a consequence, if the stack user was deleted for any reason, Heat was unable to delete the associated stack. With this update, Heat catches the "Not Found" exception in this case. As a result, stacks can still be deleted even if their associated stack user is already missing.
Story Points: ---
Clone Of:
: 1299477 (view as bug list)
Environment:
Last Closed: 2015-12-21 12:03:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1505981 None None None Never

  None (edit)
Description Steven Hardy 2015-11-27 06:22:11 EST
Description of problem:
It's not clear exactly how we get in this state, but it's possible for the delete path to encounter resources with associated users, where those users don't exist (perhaps after re-trying a previously failed delete).

How reproducible:
If you do an out of band deletion of the user, always, otherwise it seems to happen inconsistently.

Reported in openstack-heat-engine-5.0.0-1.el7ost.noarch

Steps to Reproduce:
See reproducer in linked upstream bug

Actual results:
The stack can be DELETE_FAILED, permanently.

Expected results:
A stack should never be persistently impossible to delete

Additional info:
Upstream bug, with fix merged - https://bugs.launchpad.net/heat/+bug/1505981
Comment 2 Jaromir Coufal 2015-12-01 06:12:53 EST
Ack'ed. Moving to OSP8 GA.
Comment 4 Michele Baldessari 2015-12-02 15:19:11 EST
FWIW I had again the DELETE_FAILED issue and the gerrit patch fixed it for me
Comment 5 Jaromir Coufal 2015-12-03 08:55:25 EST
We can manage to squeeze it in z3. Moving the target.
Comment 8 Zane Bitter 2015-12-03 16:33:18 EST
Still not sure of the trigger, but bug 1285495 may be related.
Comment 9 Amit Ugol 2015-12-09 08:53:30 EST
AFAIT I was always able to delete a stack in failed state in the latest versions.
I think that this issue can be ignored now because there was no way to reproduce it and I can't as well. If there is a more specific issue that we can track, please open a new bug.
Comment 11 errata-xmlrpc 2015-12-21 12:03:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2680

Note You need to log in before you can comment on or make changes to this bug.