Bug 1286256 - After restarting a ovs agent, it still drops useful flows if the neutron server is busy/down
After restarting a ovs agent, it still drops useful flows if the neutron ser...
Status: CLOSED DUPLICATE of bug 1289994
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ---
: 8.0 (Liberty)
Assigned To: lpeer
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 11:16 EST by Brent Eagles
Modified: 2016-04-26 14:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 21:59:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1515075 None None None Never
OpenStack gerrit 244465 None None None Never

  None (edit)
Description Brent Eagles 2015-11-27 11:16:00 EST
Cloned from launchpad bug 1515075.

Description:

How to reproduce:
1. Stop the neutron server to simulate it's busy/down
2. Restart an ovs agent.

After the first rpc times out(default to 60 seconds), the agent will delete some of the existing flows.

Expected:
Keep the existing flows to make sure the instances are happy.

Specification URL (additional information):

https://bugs.launchpad.net/neutron/+bug/1515075
Comment 1 Assaf Muller 2015-12-16 21:59:40 EST
Will be resolved via OSP 8 rebase before GA.

*** This bug has been marked as a duplicate of bug 1289994 ***

Note You need to log in before you can comment on or make changes to this bug.