Bug 1286279 - tools/glusterfind: add --full option to query command
tools/glusterfind: add --full option to query command
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterfind (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milind Changire
bugs@gluster.org
:
Depends On:
Blocks: 1286281 1286280
  Show dependency treegraph
 
Reported: 2015-11-27 13:01 EST by Milind Changire
Modified: 2016-06-16 09:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1286280 1286281 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:47:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milind Changire 2015-11-27 13:01:32 EST
Description of problem:
bareos requires a --full option to "glusterfind query" command to list out all files in a volume.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Output file should have url encoded file names prefixed with the "NEW " string, so that all files can be treated as new.

Additional info:
Comment 1 Vijay Bellur 2015-11-28 04:35:34 EST
REVIEW: http://review.gluster.org/12779 (tools/glusterfind: add --full option to query command) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)
Comment 2 Vijay Bellur 2016-02-15 03:28:13 EST
REVIEW: http://review.gluster.org/12779 (tools/glusterfind: add --full option to query command) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)
Comment 3 Vijay Bellur 2016-02-29 00:42:00 EST
REVIEW: http://review.gluster.org/12779 (tools/glusterfind: add --full option to query command) posted (#3) for review on master by Milind Changire (mchangir@redhat.com)
Comment 4 Vijay Bellur 2016-02-29 05:01:24 EST
REVIEW: http://review.gluster.org/12779 (tools/glusterfind: add --full option to query command) posted (#4) for review on master by Milind Changire (mchangir@redhat.com)
Comment 5 Vijay Bellur 2016-03-16 06:07:22 EDT
REVIEW: http://review.gluster.org/12779 (tools/glusterfind: add --full option to query command) posted (#5) for review on master by Milind Changire (mchangir@redhat.com)
Comment 6 Mike McCune 2016-03-28 19:03:07 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Vijay Bellur 2016-03-29 05:07:17 EDT
REVIEW: http://review.gluster.org/12779 (tools/glusterfind: add --full option to query command) posted (#6) for review on master by Milind Changire (mchangir@redhat.com)
Comment 8 Vijay Bellur 2016-03-29 05:47:55 EDT
REVIEW: http://review.gluster.org/12779 (tools/glusterfind: add --full option to query command) posted (#7) for review on master by Milind Changire (mchangir@redhat.com)
Comment 9 Vijay Bellur 2016-03-31 00:51:36 EDT
COMMIT: http://review.gluster.org/12779 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit 16a3f0d020d23978b22a07354c25c654c88163a2
Author: Milind Changire <mchangir@redhat.com>
Date:   Sat Nov 28 14:56:02 2015 +0530

    tools/glusterfind: add --full option to query command
    
    The --full option will use brickfind.py to list all files in the volume.
    The output file will contain url-encoded file names prefixed with the
    tag string to indicate that all files should be considered as new.
    The default tag string for the --full option is "NEW". This can be
    changed with the --tag-for-full-find command-line option.
    
    Change-Id: Ic85ba5db062e19df13ae9dc2de8a08eacb5c9792
    BUG: 1286279
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/12779
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
Comment 10 Niels de Vos 2016-06-16 09:47:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.