Bug 1286280 - tools/glusterfind: add --full option to query command
tools/glusterfind: add --full option to query command
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterfind (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milind Changire
bugs@gluster.org
:
Depends On: 1286281 1286279
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 13:02 EST by Milind Changire
Modified: 2016-04-19 03:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286279
Environment:
Last Closed: 2016-04-19 03:12:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milind Changire 2015-11-27 13:02:48 EST
+++ This bug was initially created as a clone of Bug #1286279 +++

Description of problem:
bareos requires a --full option to "glusterfind query" command to list out all files in a volume.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Output file should have url encoded file names prefixed with the "NEW " string, so that all files can be treated as new.

Additional info:
Comment 1 Vijay Bellur 2016-03-31 01:11:52 EDT
REVIEW: http://review.gluster.org/13864 (tools/glusterfind: add --full option to query command) posted (#1) for review on release-3.7 by Milind Changire (mchangir@redhat.com)
Comment 2 Vijay Bellur 2016-04-05 02:50:01 EDT
COMMIT: http://review.gluster.org/13864 committed in release-3.7 by Aravinda VK (avishwan@redhat.com) 
------
commit f2be482914f1bc4a653a342f03fc7826ce97ae22
Author: Milind Changire <mchangir@redhat.com>
Date:   Sat Nov 28 14:56:02 2015 +0530

    tools/glusterfind: add --full option to query command
    
    The --full option will use brickfind.py to list all files in the volume.
    The output file will contain url-encoded file names prefixed with the
    tag string to indicate that all files should be considered as new.
    The default tag string for the --full option is "NEW". This can be
    changed with the --tag-for-full-find command-line option.
    
    Change-Id: Ic85ba5db062e19df13ae9dc2de8a08eacb5c9792
    BUG: 1286280
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/12779
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    (cherry picked from commit 16a3f0d020d23978b22a07354c25c654c88163a2)
    Reviewed-on: http://review.gluster.org/13864
Comment 3 Kaushal 2016-04-19 03:12:36 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.11, please open a new bug report.

glusterfs-3.7.11 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026321.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.