Bug 1286342 - Mouse cursor vanishes
Mouse cursor vanishes
Status: CLOSED DUPLICATE of bug 1278316
Product: Fedora
Classification: Fedora
Component: wayland (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2015-11-28 05:54 EST by Martin Vysny
Modified: 2015-11-30 05:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 05:20:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Vysny 2015-11-28 05:54:56 EST
Description of problem:
I run a fair amount of XWayland-based windows (Thunderbird, Chromium, Intellij) along with Wayland native windows (gnome-terminal). I'm not yet sure what exactly causes this, but sometimes suddenly the cursor vanishes for all XWayland windows, and only appears when I move the cursor over a wayland native window, such as gnome-terminal.
Perhaps this is related: when moving the mouse cursor from wayland native window to xwayland window, the cursor retains its shape (for example it will retain its right+bottom dragging shape when leaving gnome-terminal through the bottom right corner) and is not changed to, say, the black arrow.

Version-Release number of selected component (if applicable):


How reproducible:
I do not know yet, I suspect that a few alt-tabs will cause this but I am not sure.

Steps to Reproduce:
1.
2.
3.

Actual results:
The cursor retains its shape as it was when it was leaving the native wayland window (for example, a gnome terminal).

Expected results:
Upon entering, say, Krusader, the cursor should change its shape to a black arrow.

Additional info:
Comment 1 Kamil Páral 2015-11-30 05:20:23 EST
Seems to be the same as bug 1278316.

*** This bug has been marked as a duplicate of bug 1278316 ***

Note You need to log in before you can comment on or make changes to this bug.