Bug 1286390 - Engine log flooded with errors: "Failed to find host on any provider by host name 'host.example.com'"
Engine log flooded with errors: "Failed to find host on any provider by host ...
Status: CLOSED DUPLICATE of bug 1260499
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-28 17:10 EST by Nir Soffer
Modified: 2016-02-10 14:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 04:08:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
Enging log full of these errors (303.73 KB, application/x-xz)
2015-11-28 17:10 EST, Nir Soffer
no flags Details

  None (edit)
Description Nir Soffer 2015-11-28 17:10:55 EST
Created attachment 1100004 [details]
Enging log full of these errors

Description of problem:

I don't use formeman integration, but engine logs is full of its errors.

# xzgrep org.ovirt.engine.core.bll.host.provider.foreman.SystemProviderFinder /var/log/ovirt-engine/engine.log* | wc -l
1102

# ls -lht /var/log/ovirt-engine/engine.log*
-rw-r--r--. 1 ovirt ovirt 8.8M Nov 29 00:02 /var/log/ovirt-engine/engine.log
-rw-r--r--. 1 ovirt ovirt 1.2M Nov 14 03:14 /var/log/ovirt-engine/engine.log-20151114.gz

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.6.1-0.0.master.20151113175558.git6a36a6d.fc22

How reproducible:
Always

Steps to Reproduce:
1. Run ovirt-engine, do not configure foreman

Expected results:
No forman related logs, or maybe one per engine startup.
Comment 1 Moti Asayag 2015-12-07 04:08:50 EST

*** This bug has been marked as a duplicate of bug 1260499 ***

Note You need to log in before you can comment on or make changes to this bug.