Bug 1286396 - USB mouse periodically stops working, logs fill with "usb 2-1.3: input irq status -75 received"
USB mouse periodically stops working, logs fill with "usb 2-1.3: input irq st...
Status: CLOSED DUPLICATE of bug 1277837
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-28 19:00 EST by Noel Duffy
Modified: 2016-07-11 02:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-11 02:40:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noel Duffy 2015-11-28 19:00:36 EST
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.4.0
Build Identifier: 

I recently updated to Fedora 23 from 22 using dnf. Now, every few days my USB mouse stops working and the following messages are written to /var/log/messages:

Nov 29 12:11:19 soma audit: CRED_REFR pid=18901 uid=0 auid=4294967295 ses=4294967295 msg='op=PAM:setcred grantors=pam_unix,pam_gnome_keyring acct="noeld" exe="/usr/libexec/gdm-session-worker" hostname=? addr=? terminal=? res=success'
Nov 29 12:11:28 soma dbus[1111]: [system] Activating service name='org.freedesktop.fwupd' (using servicehelper)
Nov 29 12:11:28 soma kernel: usb 1-1.3: reset high-speed USB device number 4 using ehci-pci
Nov 29 12:11:28 soma org.freedesktop.fwupd: (fwupd:18918): Fu-WARNING **: Failed to coldplug: UEFI firmware updating not supported
Nov 29 12:11:28 soma org.freedesktop.fwupd: ####################################                                                   @0229ms AsStore:load 229ms
Nov 29 12:11:28 soma org.freedesktop.fwupd: #                                                                                      @0011ms AsStore:app-info{/usr/share/app-info/xmls/fedora.xml} 10ms
Nov 29 12:11:28 soma org.freedesktop.fwupd: #                                                                                      @0011ms AsStore:store-from-file 8ms
Nov 29 12:11:28 soma org.freedesktop.fwupd: ################################                                                      @0218ms AsStore:app-info{/usr/share/app-info/xmls/fedora.xml.gz} 207ms
Nov 29 12:11:28 soma org.freedesktop.fwupd: #############################                                                         @0200ms AsStore:store-from-file 188ms
Nov 29 12:11:28 soma org.freedesktop.fwupd: #############################################  @0545ms FuMain:coldplug 291ms
Nov 29 12:11:28 soma org.freedesktop.fwupd: #                                              @0260ms FuMain:coldplug{Udev} 6ms
Nov 29 12:11:28 soma org.freedesktop.fwupd: ############################################  @0545ms FuMain:coldplug{USB} 284ms
Nov 29 12:11:28 soma org.freedesktop.fwupd: ###########################################   @0543ms FuProviderUsb:added{046d:082b} 278ms
Nov 29 12:11:28 soma dbus[1111]: [system] Successfully activated service 'org.freedesktop.fwupd'
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received
Nov 29 12:11:29 soma kernel: usb 2-1.3: input irq status -75 received

Each time I move the mouse even a fraction, hundreds of new occurrences of the "irq status -75" message appear.

Only the mouse has stopped working. I have a USB keyboard, webcam and pair of headphones that all continue to work normally.

The kernel buffer contains this:

$ dmesg -T
[Sun Nov 29 12:09:53 2015] usb 1-1.3: reset high-speed USB device number 4 using ehci-pci
[Sun Nov 29 12:09:53 2015] usb 2-1.3: input irq status -75 received
[Sun Nov 29 12:09:53 2015] usb 2-1.3: input irq status -75 received
[Sun Nov 29 12:09:53 2015] usb 2-1.3: input irq status -75 received
[Sun Nov 29 12:09:53 2015] usb 2-1.3: input irq status -75 received
[Sun Nov 29 12:09:53 2015] usb 2-1.3: input irq status -75 received
[Sun Nov 29 12:09:53 2015] usb 2-1.3: input irq status -75 received
[Sun Nov 29 12:09:53 2015] usb 2-1.3: input irq status -75 received
[Sun Nov 29 12:09:53 2015] usb 2-1.3: input irq status -75 received
[Sun Nov 29 12:09:53 2015] usb 2-1.3: input irq status -75 received

$ uname -r
4.2.6-301.fc23.x86_64

$ lsusb
Bus 002 Device 004: ID 046d:0a44 Logitech, Inc. Wired headset
Bus 002 Device 003: ID 15d9:0a4c Trust International B.V. USB+PS/2 Optical Mouse
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 046d:082b Logitech, Inc. Webcam C170
Bus 001 Device 003: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub



Reproducible: Always

Steps to Reproduce:
This problem is quite intermittent and I can't reproduce on demand. It has occurred perhaps three times in the two weeks since I upgraded to Fedora 23. I never saw it on Fedora 22 or 21.

Actual Results:  
When the problem occurs, moving the mouse does not move the mouse pointer and clicks don't work. The logs fill up with "usb 2-1.3: input irq status -75 received".


Expected Results:  
The mouse should just work.


$ usb-devices 

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 3
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=04.02
S:  Manufacturer=Linux 4.2.6-301.fc23.x86_64 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=0000:00:1a.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480 MxCh= 6
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=8087 ProdID=0020 Rev=00.00
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#=  3 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=046d ProdID=c31c Rev=64.00
S:  Manufacturer=Logitech
S:  Product=USB Keyboard
C:  #Ifs= 2 Cfg#= 1 Atr=a0 MxPwr=90mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=01 Driver=usbhid
I:  If#= 1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=usbhid

T:  Bus=01 Lev=02 Prnt=02 Port=02 Cnt=02 Dev#=  4 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=046d ProdID=082b Rev=28.25
S:  Manufacturer= 
S:  Product=Webcam C170
C:  #Ifs= 4 Cfg#= 1 Atr=80 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=0e(video) Sub=01 Prot=00 Driver=uvcvideo
I:  If#= 1 Alt= 0 #EPs= 0 Cls=0e(video) Sub=02 Prot=00 Driver=uvcvideo
I:  If#= 2 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=snd-usb-audio
I:  If#= 3 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 3
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=04.02
S:  Manufacturer=Linux 4.2.6-301.fc23.x86_64 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=0000:00:1d.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480 MxCh= 8
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=8087 ProdID=0020 Rev=00.00
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=02 Lev=02 Prnt=02 Port=02 Cnt=01 Dev#=  3 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=15d9 ProdID=0a4c Rev=01.00
S:  Product= USB OPTICAL MOUSE
C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=usbhid

T:  Bus=02 Lev=02 Prnt=02 Port=03 Cnt=02 Dev#=  4 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs=  1
P:  Vendor=046d ProdID=0a44 Rev=01.27
S:  Manufacturer=Logitech
S:  Product=Logitech USB Headset
C:  #Ifs= 4 Cfg#= 1 Atr=80 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=snd-usb-audio
I:  If#= 1 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio
I:  If#= 2 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=snd-usb-audio
I:  If#= 3 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=usbhid
Comment 1 Noel Duffy 2016-07-11 02:40:46 EDT

*** This bug has been marked as a duplicate of bug 1277837 ***

Note You need to log in before you can comment on or make changes to this bug.