Bug 1286411 - Nova fails to launch instances from RAW images
Nova fails to launch instances from RAW images
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
8.0 (Liberty)
x86_64 Linux
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: Lee Yarwood
Prasanth Anbalagan
: Triaged
: 1286410 1301472 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-29 03:55 EST by Yogev Rabl
Modified: 2016-04-07 17:14 EDT (History)
16 users (show)

See Also:
Fixed In Version: openstack-nova-12.0.0-3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:14:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Nova-compute.log (7.61 KB, text/plain)
2015-11-29 03:57 EST, Yogev Rabl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1508230 None None None Never
OpenStack gerrit 237801 None None None Never

  None (edit)
Description Yogev Rabl 2015-11-29 03:55:29 EST
Description of problem:
Nova compute fails to launch instance with RAW images. To use Ceph's capabilities, RAW images are the recommended disk format to use when both Glance's default store and Nova's instances back end storage is RADOS block device. 

Version-Release number of selected component (if applicable):
openstack-nova-compute-12.0.0-2.el7ost.noarch
python-novaclient-2.30.1-1.el7ost.noarch
python-nova-12.0.0-2.el7ost.noarch
openstack-nova-common-12.0.0-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a RAW image in Glance
2. Launch the image

Actual results:
The instance fail to launch with the errors in nova-compute.log (see attachment)

Expected results:
Instance is active 

Additional information:
A fix is already available https://review.openstack.org/#/c/237801/
Comment 1 Yogev Rabl 2015-11-29 03:57 EST
Created attachment 1100106 [details]
Nova-compute.log
Comment 4 Lee Yarwood 2015-11-30 04:15:39 EST
*** Bug 1286410 has been marked as a duplicate of this bug. ***
Comment 8 Prasanth Anbalagan 2016-01-18 15:49:25 EST
No error observed during booting an instance from RAW image. Please see logs below for further details.

***********
Version
***********

[root@lynx13 ~(keystone_admin)]# yum list installed | grep openstack-nova
openstack-nova-api.noarch            1:12.0.0-4.el7ost       @rhelosp-8.0-puddle
openstack-nova-cert.noarch           1:12.0.0-4.el7ost       @rhelosp-8.0-puddle
openstack-nova-common.noarch         1:12.0.0-4.el7ost       @rhelosp-8.0-puddle
openstack-nova-compute.noarch        1:12.0.0-4.el7ost       @rhelosp-8.0-puddle
openstack-nova-conductor.noarch      1:12.0.0-4.el7ost       @rhelosp-8.0-puddle
openstack-nova-console.noarch        1:12.0.0-4.el7ost       @rhelosp-8.0-puddle
openstack-nova-novncproxy.noarch     1:12.0.0-4.el7ost       @rhelosp-8.0-puddle
openstack-nova-scheduler.noarch      1:12.0.0-4.el7ost       @rhelosp-8.0-puddle
[root@lynx13 ~(keystone_admin)]# 


************
Logs
************

[root@lynx13 ~(keystone_admin)]# glance image-create --disk-format raw --container-format bare --name fedora --file Fedora-Cloud-Base-23-20151030.x86_64.raw 
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | 1191066f5a6770967f5c2cd0891061f7     |
| container_format | bare                                 |
| created_at       | 2016-01-18T20:43:15Z                 |
| disk_format      | raw                                  |
| id               | 5604f59c-9fd0-4a15-8a47-b5eb38e85dad |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | fedora                               |
| owner            | eeae83eb9c6249caa19533c9debbac69     |
| protected        | False                                |
| size             | 3221225472                           |
| status           | active                               |
| tags             | []                                   |
| updated_at       | 2016-01-18T20:43:37Z                 |
| virtual_size     | None                                 |
| visibility       | private                              |
+------------------+--------------------------------------+
[root@lynx13 ~(keystone_admin)]# 
[root@lynx13 ~(keystone_admin)]# 
[root@lynx13 ~(keystone_admin)]# glance image-list
+--------------------------------------+--------+
| ID                                   | Name   |
+--------------------------------------+--------+
| 28de3499-7699-467f-9adb-281ee929fe91 | cirros |
| 5604f59c-9fd0-4a15-8a47-b5eb38e85dad | fedora |
+--------------------------------------+--------+
[root@lynx13 ~(keystone_admin)]# 
[root@lynx13 ~(keystone_admin)]# 
[root@lynx13 ~(keystone_admin)]# glance image-show  5604f59c-9fd0-4a15-8a47-b5eb38e85dad
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | 1191066f5a6770967f5c2cd0891061f7     |
| container_format | bare                                 |
| created_at       | 2016-01-18T20:43:15Z                 |
| disk_format      | raw                                  |
| id               | 5604f59c-9fd0-4a15-8a47-b5eb38e85dad |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | fedora                               |
| owner            | eeae83eb9c6249caa19533c9debbac69     |
| protected        | False                                |
| size             | 3221225472                           |
| status           | active                               |
| tags             | []                                   |
| updated_at       | 2016-01-18T20:43:37Z                 |
| virtual_size     | None                                 |
| visibility       | private                              |
+------------------+--------------------------------------+

[root@lynx13 ~(keystone_admin)]# nova list
+--------------------------------------+------+--------+------------+-------------+---------------------+
| ID                                   | Name | Status | Task State | Power State | Networks            |
+--------------------------------------+------+--------+------------+-------------+---------------------+
| b096d63f-1695-47b8-96b7-ab537c6598e6 | vm1  | ACTIVE | -          | Running     | public=172.24.4.227 |
+--------------------------------------+------+--------+------------+-------------+---------------------+
[root@lynx13 ~(keystone_admin)]# 
[root@lynx13 ~(keystone_admin)]# 

[root@lynx13 ~(keystone_admin)]# nova boot --flavor 2 --image fedora vm_rawimage
+--------------------------------------+-----------------------------------------------+
| Property                             | Value                                         |
+--------------------------------------+-----------------------------------------------+
| OS-DCF:diskConfig                    | MANUAL                                        |
| OS-EXT-AZ:availability_zone          |                                               |
| OS-EXT-SRV-ATTR:host                 | -                                             |
| OS-EXT-SRV-ATTR:hypervisor_hostname  | -                                             |
| OS-EXT-SRV-ATTR:instance_name        | instance-00000002                             |
| OS-EXT-STS:power_state               | 0                                             |
| OS-EXT-STS:task_state                | scheduling                                    |
| OS-EXT-STS:vm_state                  | building                                      |
| OS-SRV-USG:launched_at               | -                                             |
| OS-SRV-USG:terminated_at             | -                                             |
| accessIPv4                           |                                               |
| accessIPv6                           |                                               |
| adminPass                            | JLATw5ZSDoxs                                  |
| config_drive                         |                                               |
| created                              | 2016-01-18T20:47:12Z                          |
| flavor                               | m1.small (2)                                  |
| hostId                               |                                               |
| id                                   | 9973315b-bf55-42a4-a22a-5b869bb1a144          |
| image                                | fedora (5604f59c-9fd0-4a15-8a47-b5eb38e85dad) |
| key_name                             | -                                             |
| metadata                             | {}                                            |
| name                                 | vm_rawimage                                   |
| os-extended-volumes:volumes_attached | []                                            |
| progress                             | 0                                             |
| security_groups                      | default                                       |
| status                               | BUILD                                         |
| tenant_id                            | eeae83eb9c6249caa19533c9debbac69              |
| updated                              | 2016-01-18T20:47:12Z                          |
| user_id                              | 348245d1b9ae49a7b61aa196ab46d17f              |
+--------------------------------------+-----------------------------------------------+
[root@lynx13 ~(keystone_admin)]# nova list
+--------------------------------------+-------------+--------+------------+-------------+---------------------+
| ID                                   | Name        | Status | Task State | Power State | Networks            |
+--------------------------------------+-------------+--------+------------+-------------+---------------------+
| b096d63f-1695-47b8-96b7-ab537c6598e6 | vm1         | ACTIVE | -          | Running     | public=172.24.4.227 |
| 9973315b-bf55-42a4-a22a-5b869bb1a144 | vm_rawimage | BUILD  | spawning   | NOSTATE     | public=172.24.4.228 |
+--------------------------------------+-------------+--------+------------+-------------+---------------------+
[root@lynx13 ~(keystone_admin)]# 
[root@lynx13 ~(keystone_admin)]# nova list
+--------------------------------------+-------------+--------+------------+-------------+---------------------+
| ID                                   | Name        | Status | Task State | Power State | Networks            |
+--------------------------------------+-------------+--------+------------+-------------+---------------------+
| b096d63f-1695-47b8-96b7-ab537c6598e6 | vm1         | ACTIVE | -          | Running     | public=172.24.4.227 |
| 9973315b-bf55-42a4-a22a-5b869bb1a144 | vm_rawimage | ACTIVE | -          | Running     | public=172.24.4.228 |
+--------------------------------------+-------------+--------+------------+-------------+---------------------+
Comment 9 Jon Schlueter 2016-01-29 11:04:38 EST
*** Bug 1301472 has been marked as a duplicate of this bug. ***
Comment 10 Lee Yarwood 2016-02-12 06:26:37 EST
(In reply to Prasanth Anbalagan from comment #8)
> No error observed during booting an instance from RAW image. Please see logs
> below for further details.

Just to confirm that you were using ceph as the instance store to verify this correct?
Comment 11 Yogev Rabl 2016-02-15 03:30:00 EST
(In reply to Lee Yarwood from comment #10)
> (In reply to Prasanth Anbalagan from comment #8)
> > No error observed during booting an instance from RAW image. Please see logs
> > below for further details.
> 
> Just to confirm that you were using ceph as the instance store to verify
> this correct?

Yes I am.
Comment 12 errata-xmlrpc 2016-04-07 17:14:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.